bugGnash - The GNU Flash player - Bugs: bug #16684, gnash cvs 1.28 as-needed support...

 
 

bug #16684: gnash cvs 1.28 as-needed support for OPENGL

Submitted by:  None
Submitted on:  Sun 28 May 2006 08:10:55 PM UTC  
Votes:  1  
 
Category:  None Severity:  3 - Normal
Release:  None Status:  Fixed
Privacy:  Public Assigned to:  Rob Savoye <rsavoye>
Open/Closed:  Closed

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Sat 12 Aug 2006 11:06:04 PM UTC, comment #7: 

When I upgraded my machine recently, I finally fixed my local problem with this patch, so it's now been checked in.

Rob Savoye <rsavoye>
Project AdministratorIn charge of this item.
Sat 12 Aug 2006 11:04:11 PM UTC, comment #6: 

This works for me now in the latest cvs HEAD. Can someone please close this bug?

Stefan Schweizer <genstef>
Tue 30 May 2006 05:21:17 AM UTC, comment #5: 

The patch works on my slow FC4 machine, it's just on Ubuntu "Breezy" that's I have this problem. I'm not claiming any distro is better, I run Gentoo, Fedora, and Ubuntu here as well, plus a collection of other Unixes. My x86 Ubuntu machine is pretty much a stock installation, so having OPENGL_LIBS break something isn't good, and would likely effect more people than just myself. it would be good to know if this patch does work for you on Ubuntu, because if it does, maybe there is something weird about my installation, which would help me track down why this doesn't work for me.

Rob Savoye <rsavoye>
Project AdministratorIn charge of this item.
Tue 30 May 2006 02:54:55 AM UTC, comment #4: 

I could test the patch on Ubuntu, Gentoo, and Fedora if you'd like. Doesn't make sense to claim one distro is superior to another though we may prefer one to another one. I prefer Gentoo, but I've setup Ubuntu, and Fedora boxes lately, and I'm the primary admin for those boxes.

Brian Beardall <rapsure>
Mon 29 May 2006 05:30:55 PM UTC, comment #3: 

What makes no sense is insulting people. This will get fixed when I figure out why this breaks my Ubuntu system. I cannot risk screwing up my main development machine when there are piles of more important issues to fix. This shouldn't hold up anybody, it's merely an optimization thing. It may get fixed sooner than later, all I said was I can't commit this patch now.

Whether you think Ubuntu users are fools is a meaningless detail. I'll resist saying anything about my miserable experences with Gentoo...

Rob Savoye <rsavoye>
Project AdministratorIn charge of this item.
Mon 29 May 2006 05:18:22 PM UTC, comment #2: 

so because you ubunta fools with OPENGL files your gonna hold up others from testing and moving forward with as-needed support? This does not make any sense.

Jory A. Pratt <anarchpenguin>
Mon 29 May 2006 02:57:49 PM UTC, comment #1: 

For me, adding OPENGL_LIBS to the Makefile for libbase makes a Gnash executable that never instantiates the graphic in the frame, and never plays the movie. Until I figure out why this patch (which has also been submitted before) doesn't work on my Ubuntu machine, I can't committ this patch.

Rob Savoye <rsavoye>
Project AdministratorIn charge of this item.
Sun 28 May 2006 08:10:55 PM UTC, original submission:  

Here is a patch to fix the last issue I have found with --as-needed support in latest CVS as of 20060528. If this is not correct let me know and I will adjust it for you all. Thanks for the great work and keep the ball high.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #10486:  gnash-as-needed.diff added by genstef (1KiB - text/plain - New patch against curent cvs including an additional hunk for new as-needed library dependency problems)
file #10076:  gnash-opengl.diff added by genstef (794B - text/x-patch - gnash-opengl.diff - against 20060530 cvs)
file #10068:  gnash-20060528-opengl.diff added by None (1KiB - text/x-patch - gnash-20060528-opengl.diff)

 

Depends on the following items: None found

Items that depend on this one: None found

 

CC list is empty

 

Do you think this task is very important?
If so, you can add your encouragement to it.
This task has 1 encouragement so far.

Only logged-in users can vote.

 

 

 

Follow 11 latest changes.

Date Changed by Updated Field Previous Value => Replaced by
2006-08-12 rsavoye StatusPostponed => Fixed
    Open/ClosedOpen => Closed
2006-08-08 genstef Attached File- => Added gnash-as-needed.diff, #10486
2006-05-30 genstef Attached File- => Added gnash-opengl.diff, #10076
    Carbon-Copy- => Added genstef@gentoo.org
2006-05-30 rsavoye StatusNone => Postponed
2006-05-29 rsavoye StatusPostponed => None
2006-05-29 rsavoye StatusNone => Postponed
    Assigned toNone => rsavoye
2006-05-29 anarchpenguin Carbon-Copy- => Added anarchpenguin
2006-05-28 None Attached File- => Added gnash-20060528-opengl.diff, #10068

Back to the top


Powered by Savane 3.5