bugGNU Health - Bugs: bug #63152, Surgery crashes when imaging/lab...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #63152: Surgery crashes when imaging/lab module is not activated

Submitter:  Sergi Almacellas Abellana <pokoli>
Submitted:  Tue 04 Oct 2022 10:50:30 AM UTC
 
Category:  Tryton Severity:  3 - Normal
Item Group:  None Status:  Duplicate
Privacy:  Public Assigned to:  meanmicio
Open/Closed:  Closed Release:  4.1.0
Module:  health_surgery Component:  Hospital Management

Mon 12 Dec 2022 02:41:14 PM UTC, comment #3: 

Related to bug #63496

Luis Falcon <meanmicio>
Project Administrator
Tue 04 Oct 2022 02:57:02 PM UTC, comment #2: 

Thank you, Sergi!

Due to the current functionality of the surgery package, and because the nature of surgical context, both health_lab and health_surgery should be dependencies of health_surgery.

Bests
Luis

Luis Falcon <meanmicio>
Project Administrator
Tue 04 Oct 2022 10:53:15 AM UTC, comment #1: 

It also crashen when the health_lab is not activated

Traceback (most recent call last):
  File "/home/pokoli/.virtualenvs/gnuhealth/bin/trytond-admin", line 23, in <module>
    admin.run(options)
  File "/home/pokoli/.virtualenvs/gnuhealth/lib/python3.10/site-packages/trytond/admin.py", line 53, in run
    pool.init(update=options.update, lang=list(lang),
  File "/home/pokoli/.virtualenvs/gnuhealth/lib/python3.10/site-packages/trytond/pool.py", line 164, in init
    restart = not load_modules(
  File "/home/pokoli/.virtualenvs/gnuhealth/lib/python3.10/site-packages/trytond/modules/__init__.py", line 438, in load_modules
    _load_modules(update)
  File "/home/pokoli/.virtualenvs/gnuhealth/lib/python3.10/site-packages/trytond/modules/__init__.py", line 406, in _load_modules
    load_module_graph(graph, pool, update, lang)
  File "/home/pokoli/.virtualenvs/gnuhealth/lib/python3.10/site-packages/trytond/modules/__init__.py", line 238, in load_module_graph
    cls.__register__(module)
  File "/home/pokoli/.virtualenvs/gnuhealth/lib/python3.10/site-packages/trytond/model/modelsql.py", line 264, in _register_
    ref_model = pool.get(field.model_name)
  File "/home/pokoli/.virtualenvs/gnuhealth/lib/python3.10/site-packages/trytond/pool.py", line 187, in get
    return self._pool[self.database_name][type][name]
KeyError: 'gnuhealth.lab'

Sergi Almacellas Abellana <pokoli>
Project Member
Tue 04 Oct 2022 10:50:30 AM UTC, original submission:  

Since https://hg.savannah.gnu.org/hgweb/health/rev/b6717840dc19 updating the health_surgery module crashes when the health_imaging module is not activated.

Here is the traceback:

Traceback (most recent call last):
  File "/home/pokoli/.virtualenvs/gnuhealth/bin/trytond-admin", line 23, in <module>
    admin.run(options)
  File "/home/pokoli/.virtualenvs/gnuhealth/lib/python3.10/site-packages/trytond/admin.py", line 53, in run
    pool.init(update=options.update, lang=list(lang),
  File "/home/pokoli/.virtualenvs/gnuhealth/lib/python3.10/site-packages/trytond/pool.py", line 164, in init
    restart = not load_modules(
  File "/home/pokoli/.virtualenvs/gnuhealth/lib/python3.10/site-packages/trytond/modules/__init__.py", line 438, in load_modules
    _load_modules(update)
  File "/home/pokoli/.virtualenvs/gnuhealth/lib/python3.10/site-packages/trytond/modules/__init__.py", line 406, in _load_modules
    load_module_graph(graph, pool, update, lang)
  File "/home/pokoli/.virtualenvs/gnuhealth/lib/python3.10/site-packages/trytond/modules/__init__.py", line 238, in load_module_graph
    cls.__register__(module)
  File "/home/pokoli/.virtualenvs/gnuhealth/lib/python3.10/site-packages/trytond/model/modelsql.py", line 264, in _register_
    ref_model = pool.get(field.model_name)
  File "/home/pokoli/.virtualenvs/gnuhealth/lib/python3.10/site-packages/trytond/pool.py", line 187, in get
    return self._pool[self.database_name][type][name]
KeyError: 'gnuhealth.imaging.test.result'

A dependency with the health_imaging should be added (maybe optional one) to fix it.

Sergi Almacellas Abellana <pokoli>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by meanmicio (Posted a comment)
  • -email is unavailable- added by pokoli (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

     

     

     

    Follow 6 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2022-12-12 meanmicio StatusConfirmed Duplicate
        Open/ClosedOpen Closed
        ReleaseNone 4.1.0
    2022-10-04 meanmicio StatusNone Confirmed
        Assigned toNone meanmicio
    2022-10-04 pokoli SummarySurgery crashes when imaging module is not activated Surgery crashes when imaging/lab module is not activated

    Back to the top

    Powered by Savane 3.10