bugGNU gettext - Bugs: bug #54741, [feature request] Wrap like msgcat...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #54741: [feature request] Wrap like msgcat does by default

Submitter:  Julien Palard <mdk2>
Submitted:  Thu 27 Sep 2018 09:14:43 AM UTC
 
Category:  PO mode Severity:  3 - Normal
Item Group:  None Status:  Not a Bug
Privacy:  Public Assigned to:  haible
Open/Closed:  Closed
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       No canned response available

 

Wed 10 Oct 2018 11:22:37 AM UTC, comment #2: 

Hi Bruno thanks for taking care,

You're right, I need them to be wrapped after an edit session.

> why does it matter to you whether the messages' presentation is wrapped or not?


To get readable git log. Every other contributors on the repo (https://github.com/python/python-docs-fr/) uses gettext, which wraps by default, and I use emacs, which unwraps every line I touch. If I don't re-wrap the files manually using msgcat before commiting it mess up git logs.

Also the "you can ask everybody to configure their gettext to unwrap, so everyone use unwrapped lines and git logs stay clear" is not acceptable, we like wrapped lines, as it makes paragraphs more readable in patch format / git log / github review tab.

Julien Palard <mdk2>
Sun 30 Sep 2018 08:55:26 PM UTC, comment #1: 

1) po-mode exists only in Emacs, and Emacs has a reasonable way to display long lines (through continuation lines); I verified this both in the X11 UI and the terminal-mode UI ('emacs -nw'). Also in both modes, the user can increase the width of the window interactively.

So, what would be the benefit?

2) As far as I understand it, the default wrapping is meant to accommodate environments where long lines are not properly displayed.

Therefore I would possibly understand if you were asking for an msgcat-with-wrapping run at the beginning of an edit session with PO mode. But at the end of an edit session, when you are handing over the PO file to other tools, why does it matter to you whether the messages' presentation is wrapped or not?

Bruno Haible <haible>
Project Administrator
Thu 27 Sep 2018 09:14:43 AM UTC, original submission:  

While editing entries in a wrapped po pofiles, po-mode unwrap them at save time (C-c).

I think it would be nice to expose a way to write them wrapped, or even to wrap them by default, as msgcat does (in fact, I fix my po files using msgcat after editing them (in fact I use a python script to do this for me, misnamed poindent, should be named powrap maybe https://pypi.org/project/poindent/)

Bests

Julien Palard <mdk2>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by haible (Posted a comment)
  • -email is unavailable- added by mdk2 (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-09-30 haible StatusNone Not a Bug
        Assigned toNone haible
        Open/ClosedOpen Closed

    Back to the top


    Powered by Savane 3.9