bugGNU arch -- a revision control system - Bugs: bug #6594, Incorrect redo after update.

 
 

bug #6594: Incorrect redo after update.

Submitter:  Invalid User ID <#25500>
Submitted:  Mon 17 Nov 2003 09:52:57 AM UTC
   
 
Category:  tla Severity:  3 - Normal
Item Group:  bug Status:  None
Privacy:  Public Open/Closed:  Open
Release:  tla-1.1pre8
Fixed Release: 
Merge Request?:  None
Your Archive Name: 
Your Archive Location: 
Assigned to:  None
* Mandatory Fields

Add a New Comment Rich Markup
   

Sun 23 Nov 2003 12:48:40 PM UTC, comment #1: 

this may be related to the 'incorrect sorting of undo dirs' bug. I've merged the fix for that into my rbtcollins@hotmail.com--barch/tla--integration--1.1 branch. Perhaps you could try and see? Failing that, if you generate a test case, I'll happily add that to the test scripts, so we'll know when it's fixed :}

Robert Collins <robertc>
Mon 17 Nov 2003 09:52:57 AM UTC, original submission:  

If tree contains some uncommited modifications and it also contains ,,undo-N dir with some other changes, then on making 'update' in the tree the tla creates ,,undo-N+1 dir for uncommited modifications, but on the final step of 'update' redoes changeset from ,,undo-N dir.

Invalid User ID <#25500>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

CC list is empty

 

There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

Only logged-in users can vote.

 

No changes have been made to this item

Back to the top

Powered by Savane 3.13-7c56.
Corresponding source code