bugGNU Octave - Bugs: bug #61299, Command window freezes after...

 
 

bug #61299: Command window freezes after console crash with non-English keyboard layout

Submitted by:  None
Submitted on:  Wed 06 Oct 2021 02:27:04 PM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Segfault, Bus Error, etc.
Status:  Need Info Assigned to:  None
Originator Name:  Alain Rime Originator Email:  -email is unavailable-
Open/Closed:  Open Release:  dev
Operating System:  Microsoft Windows

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Thu 14 Oct 2021 07:01:06 AM UTC, comment #11: 

Is this a combining/composing key? What might be happening is that a combined character is created that isn't supported. Or a combining character without a valid character to which it can be combined is sent to the conhost which causes it to crash...

Maybe the sequence that causes the crash is: "¨", "Alt Gr"+"]" ?
Or: "Alt Gr"+"]", "¨", "Alt Gr"+"]" ?

I'm not sure why uninstalling and re-installing the keyboard layout makes a difference. Or is it a slightly different keyboard layout that is being re-installed?

I hope all of these issues will disappear when/if we change a cross-platform Qt widget for the command window...

Markus Mützel <mmuetzel>
Project Member
Wed 13 Oct 2021 01:57:42 PM UTC, comment #10: 

Thank you for your help.
I think that the problem appears when I press "AltGR+]" on my keyboard (but not every times). In my case the third time !!!

I find a "solution" in uninstalling Swiss French keyboard and re-install it after.
So the problem in Octave disappears (but a have to fix little issues in Excel).

Thank you a lot.
Alain

Alain Rime <rimealain>
Fri 08 Oct 2021 07:16:44 AM UTC, comment #9: 

Thank you for checking with a different keyboard layout.

To be clear: Ideally Octave would work without issues on any keyboard layout. If it doesn't, it is a bug.

It would be nice if we had steps to reproduce the issue. Which key presses, key combinations or key press sequences are the minimum to reproduce the issue?

Anyways, the fix would probably be to use a replacement for the console host on Windows. There are ongoing efforts to do that. But it is a longer process. See e.g.: https://octave.discourse.group/t/new-command-window-widget/501

It's very unlikely that this will be fixed during the Octave 6.x cycle which is about to end. Setting the release to "dev".

Re-titling to better describe the probable underlying issue.

Markus Mützel <mmuetzel>
Project Member
Fri 08 Oct 2021 05:58:49 AM UTC, comment #8: 

Hello, I just test the use of American English keyboard on my office's PC and the problem disappear. All is right.
Thank you for your help !
Octave is a very great tool for teaching engineering.

Alain Rime <rimealain>
Thu 07 Oct 2021 12:12:21 PM UTC, comment #7: 

On my home computer, typing """ (I can't type it here) make no problem

Alain Rime <rimealain>
Thu 07 Oct 2021 10:00:17 AM UTC, comment #6: 

Looking at the keyboard layout, it might be possible that the issue arises when you (accidentally) enter a diaresis "¨". That seems to share the same key with the "]" character when it isn't combined with "Alt Gr".

Could you please check if entering "¨" (maybe followed by space or enter) triggers the issue with a Swiss French keyboard layout?

Markus Mützel <mmuetzel>
Project Member
Thu 07 Oct 2021 09:10:55 AM UTC, comment #5: 

Yes, it is possible because sometimes when I type a "]" (with AltGr key), a "5" or a "P" apprears in the same time.
I work all this morning on a other PC with matrix (in the workspace) without problem.
I will try to work with a english Keyboard tomorow and I'll give you the result.
Thanks for your help.

Alain Rime <rimealain>
Thu 07 Oct 2021 08:23:35 AM UTC, comment #4: 

My guess is that you might be accidentally entering a non-ASCII character.
Are there neighboring keys or key combinations close to ']' on the Swiss French keyboard layout that might result in a non-ASCII character being entered?
Does entering that character willingly also trigger the issue you are seeing?

Markus Mützel <mmuetzel>
Project Member
Thu 07 Oct 2021 06:48:05 AM UTC, comment #3: 

Yes, I'm using Swiss French keyboard. I will try to change my keybord (tomorow, I'm not at office today). I will give you news.

For other purpose I use Octave without problem. It seems to appens only with matrix.
I just tested on a my home PC and this don't appens (with Swiss French Kb).

Alain Rime <rimealain>
Wed 06 Oct 2021 04:58:59 PM UTC, comment #2: 

Are you using a non-English keyboard layout?

Octave uses the Windows console for its command line.
Unfortunately, bug #59495 can cause the underlying Windows console to crash on entering certain non-ASCII characters. That can leave you with a frozen command window.

Could it be that you are hitting the same bug?

Markus Mützel <mmuetzel>
Project Member
Wed 06 Oct 2021 02:35:53 PM UTC, comment #1: 

for reference the octave commands/output contained in the image are:

>> Ai=[12 20]
Ai =

   12   20

>> ygi=[1.5 3.5]
ygi =

   1.5000   3.5000

>> zgi=[2 6]

suggesting the program is freezing after hitting enter on that last line.

I'm unable to reproduce this on my windows system, as entering the last command creates a zgi vector as expected.

@Alain, do you get this freezing behavior with any other combinations of inputs? is it always the third command? is it always after a certain amount of time? is there any other information you can figure out about what you/your pc is doing when this freeze occurs?

Nicholas Jankowski <nrjank>
Project Member
Wed 06 Oct 2021 02:27:04 PM UTC, original submission:  

When I introduce the 3 little vector (see attached picture) Octave freeze and the CPU use increase a lot.
It freeze every time I introduce this vectors. I have the same problem with version 6.2.0.
I'm using Windows 10 Education version 20H2.
Otherwise Octave is a beautiful tool, Thanks

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #52055:  Octave_6_3_bug.JPG added by None (134KiB - image/jpeg)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rimealain (Posted a comment)
  • -email is unavailable- added by mmuetzel (Posted a comment)
  • -email is unavailable- added by nrjank (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2021-10-08 mmuetzel Item GroupNone => Segfault, Bus Error, etc.
        Release6.3.0 => dev
        SummaryOctave GUI freeze after introduction of 3 little vector in workspace => Command window freezes after console crash with non-English keyboard layout
    2021-10-06 nrjank StatusNone => Need Info
    2021-10-06 None Attached File- => Added Octave_6_3_bug.JPG, #52055

    Back to the top


    Powered by Savane 3.7