bugDenemo - Bugs: bug #56400, [ Japanese windows10 ]Denemo font...

 
 

bug #56400: [ Japanese windows10 ]Denemo font unvisible

Submitted by:  None
Submitted on:  Mon 27 May 2019 06:05:10 PM UTC  
 
Category:  None Severity:  3 - Normal
Item Group:  None Status:  Need Info
Privacy:  Public Assigned to:  None
Open/Closed:  Open

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Wed 29 May 2019 02:19:39 PM UTC, comment #8: 

The tooltip too is not displaying correctly.
Altogether this is puzzling. In the version 2.2.0 the Japanese translation file shows this entry:

msgid "Add Non-Printing Bookmark"
msgstr "名前付きブックマークを追加"

but in your picture that menu item appears untranslated.

I think the only practical thing to do is to delete the ja.* files that do the translation and use the English version.

Richard Shann <rshann>
Project Administrator
Wed 29 May 2019 11:28:31 AM UTC, comment #7: 

Also, add
Playback view does not work with denemo-2.2.0 on Windows 10.

Blackcat

Anonymous
Wed 29 May 2019 11:20:33 AM UTC, comment #6: 

This is about denemo-2.2.0-0.
hover over is

>> If you set Help->Turn off Excessive


https://imgur.com/a/AN1neeE

Anonymous
Wed 29 May 2019 11:15:42 AM UTC, comment #5: 

This is about denemo-2.2.0-0.

>> If you set Help->Turn off Excessive

Tooltips to on (so that you get all the help available) and then hover over
the strange characters you should get a pop-up explaining what they are. Does
anything happen when you click on them?

hover over is
https://imgur.com/a/ZumOQE4

Also, I'm worried, but the depth of the Denemo window is the top. Even when switching applications, the Denemo window widget is displayed independently on other applications.


Anonymous
Tue 28 May 2019 05:00:11 PM UTC, comment #4: 

One other thing: you can change the font Denemo uses via
Edit->Change Preferences->Miscellaneous->Default Font Name

If you set this to a font with the Japanese characters then the button should become legible. The downside is that the specially-designed glyphs for the note shapes (see the Notes->Edit Duration menu, for example) will become illegible.
The solution would be to merge the Japanese characters into the denemo.ttf font. This can be done with Fontforge.

Richard Shann <rshann>
Project Administrator
Tue 28 May 2019 03:18:54 PM UTC, comment #3: 

If your are right then what is showing is the Snippets bar - Choose View->Snippets and it should disappear. In which case what is showing is a button that should be labelled "Create Snippet"
which in the current ja translation is "スニペットを作成" (that translation was updated yesterday, so may not be the same).

You can turn off the translation by setting the environment variable LANGUAGE to an appropriate value - in UNIX

export LANGUAGE=en && denemo
should work.

Richard Shann <rshann>
Project Administrator
Tue 28 May 2019 11:06:18 AM UTC, comment #2: 

I think the missing charactors are transrated from English.
In this case maybe Japanese font.

I do not know whether it is correct, but it may also be against the developer's basic policy, but instead of automatically replacing the interface font with the translated language, I explicitly select the language I want to use I think it is a much better software if you can.

In a language such as Japanese, which is not a major at all, if it is automatically replaced by software, what should have been displayed and what happened when the character is not replaced correctly It can not be judged that. If you can switch languages, that barrier is eased one step.

Blackcat

Anonymous
Tue 28 May 2019 08:48:36 AM UTC, comment #1: 

The fonts you show are all the ones needed, and they are showing correctly in the palette. I don't know what that line of strange characters/icons is between the "Tools" icon line and the Main Menu. The things that can appear here (depending on the settings in the View menu) are the Playback Controls, the MIDI in controls and the Snippets. If you set Help->Turn off Excessive Tooltips to on (so that you get all the help available) and then hover over the strange characters you should get a pop-up explaining what they are. Does anything happen when you click on them?
I confess to being puzzled, but 2.2.0 is a long time ago and for practical purposes, please test
http://www.denemo.org/~jjbenham/mxe/denemo.zip
which does not need installing and gives you the proposed 2.3 version.

Richard Shann <rshann>
Project Administrator
Mon 27 May 2019 06:05:10 PM UTC, original submission:  

I installded denemo 2.2.0 from denemo-2.2.0-0.mingw.exe

A few font in Denemo became like this

https://imgur.com/a/sPiQJmf

I installed 3 of truetypefont and restarted windows after installation.

What font does this need?

Blackcat

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #47000:  002.JPG added by None (57KiB - image/jpeg)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rshann (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-05-29 None Attached File- => Added 002.JPG, #47000
    2019-05-28 rshann StatusNone => Need Info

    Back to the top


    Powered by Savane 3.6