bugGNU Octave - Bugs: bug #55712, [octave forge] (control) runtests...

 
 

bug #55712: [octave forge] (control) runtests for of-control crashes Octave randomly

Submitted by:  Markus Mützel <mmuetzel>
Submitted on:  Thu 14 Feb 2019 08:42:18 PM UTC  
 
Category:  Octave Forge Package Severity:  3 - Normal
Priority:  5 - Normal Item Group:  None
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  other Operating System:  Microsoft Windows

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Mon 18 Feb 2019 04:20:10 PM UTC, comment #11: 

Ok. Thanks for tracking this down.

Closing as a duplicate of bug #53330.

Markus Mützel <mmuetzel>
Project Member
Mon 18 Feb 2019 04:18:05 PM UTC, comment #10: 

Either works for me - the repo version compiles natively in installed mxe so when released shouldn't be an issue for anyone upgrading.

John Donoghue <lostbard>
Project Member
Mon 18 Feb 2019 03:54:25 PM UTC, comment #9: 

Should we pick these changes for MXE Octave as well.
I am now leaning towards waiting for the next release of the control package.

Markus Mützel <mmuetzel>
Project Member
Mon 18 Feb 2019 03:45:34 PM UTC, comment #8: 

That's looks like it fixed I for me, so with is really just a duplicate of bug #53330

John Donoghue <lostbard>
Project Member
Mon 18 Feb 2019 03:40:16 PM UTC, comment #7: 

changes was meant to mean chances

Im trying the latest from mercurial to see if it crashes

John Donoghue <lostbard>
Project Member
Mon 18 Feb 2019 03:35:33 PM UTC, comment #6: 

Whats the changes, it is the same as this https://savannah.gnu.org/bugs/index.php?53330

Which has been fixed in dev, but isnt in our patched control

John Donoghue <lostbard>
Project Member
Mon 18 Feb 2019 02:55:43 PM UTC, comment #5: 

Single stepping through the .m code doesnt have any errors but must be messing up the stack someway as it is when the .m function is returning back.

John Donoghue <lostbard>
Project Member
Sat 16 Feb 2019 10:51:43 AM UTC, comment #4: 

With Octave from stable (hg id da8ebed6d56e and MXE Octave hg id 8b4d4e06075d) without having stripped symbols, I ran the following after attaching Octave to gdb:

pkg load control
test care

This caused a SIGTRAP. Continuing from there didn't crash immediately but an unknown signal was caught that finally crashed Octave.
Please see the attached log with backtraces at both signals.

This isn't reproducible 100% for me. Sometimes the test passes, sometimes it crashes Octave. If it doesn't crash Octave the first time I run the test, it looks like it can run hundreds of times without crashing Octave.

(file #46279)

Markus Mützel <mmuetzel>
Project Member
Fri 15 Feb 2019 05:27:52 PM UTC, comment #3: 

ok

jtst loading the control package and running 'test care' usually will crash for me.

John Donoghue <lostbard>
Project Member
Fri 15 Feb 2019 04:44:17 PM UTC, comment #2: 

This is with Windows 10 1810 64bit.
Octave installed with the official installer. Control 3.1.0 as packaged with the installer.

I am not sure that the last test running really is btaconred. It is the last that I could read in the command window. And it was definitely the one that stuck on screen when I caught the error with gdb (see bug #55670). But maybe there is some buffering going on.

Today I think I am able to read "care" before the Octave window disappears.

Markus Mützel <mmuetzel>
Project Member
Fri 15 Feb 2019 03:18:09 PM UTC, comment #1: 

which version and type of windows ?

John Donoghue <lostbard>
Project Member
Thu 14 Feb 2019 08:42:18 PM UTC, original submission:  

Running the tests of the control package with Octave 4.4.1 randomly crashes at the third test (btaconred):

>> pkg load control
>> which damp
'damp' is a function from the file C:\Octave\OCTAVE~1.1\share\octave\packages\control-3.1.0\damp.m
>> runtests C:\Octave\OCTAVE~1.1\share\octave\packages\control-3.1.0\

I'll try to create a backtrace with gdb including symbols. (Might take a few days.)

See also bug #55670 for a backtrace without symbols with Octave 5.0.91:
https://savannah.gnu.org/bugs/index.php?55670#comment8

Markus Mützel <mmuetzel>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #46279:  bug55712_gdb_bt_with_symbols.log added by mmuetzel (50KiB - application/octet-stream)

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by lostbard (Posted a comment)
  • -email is unavailable- added by mmuetzel (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 6 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-02-18 mmuetzel Dependencies- => Depends on bugs #53330
    2019-02-18 mmuetzel StatusNone => Duplicate
        Open/ClosedOpen => Closed
    2019-02-16 mmuetzel Attached File- => Added bug55712_gdb_bt_with_symbols.log, #46279
    2019-02-14 mtmiller Carbon-CopyRemoved mtmiller => -
    2019-02-14 mmuetzel Carbon-Copy- => Added mtmiller

    Back to the top


    Powered by Savane 3.5