bugGNU Octave - Bugs: bug #55284, communications build fails:...

 
 

bug #55284: communications build fails: octave/config.h not found

Submitted by:  Andrew Janke <apjanke>
Submitted on:  Wed 26 Dec 2018 05:05:30 AM UTC  
 
Category:  Octave Forge Package Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Build Failure
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  4.4.0 Operating System:  Any

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 27 Dec 2018 07:17:10 PM UTC, comment #3: 

Closing as duplicate of #46521

Thanks for the bug report. This particular bug has already been
reported into our bug tracking system, but please feel free to
report any further bugs you find.

John Donoghue <lostbard>
Project Member
Thu 27 Dec 2018 06:15:27 PM UTC, comment #2: 

I see; thanks. 46521 looks like it covers this. This bug can be closed as a duplicate. (I don't see an option to close it myself.)

Andrew Janke <apjanke>
Thu 27 Dec 2018 12:47:58 PM UTC, comment #1: 

There are several bug reports already for communications. The patch on https://savannah.gnu.org/bugs/?46521 should at least get it to build as config.h is only one of the issues with the package.

John Donoghue <lostbard>
Project Member
Wed 26 Dec 2018 05:05:30 AM UTC, original submission:  

Looks like the communications forge package is using the deprecated/removed octave/config.h header file. I think it needs to be updated to use the new header arrangement.

References:

>> pkg install -forge communications
In file included from galois.cc:galois-def.cc:21:2110:
: ./galois.hfatal error:: 24:10: 'octave/config.h' fatal errorfile:  not found
'octave/config.h' file not found
#include <octave/config.h>
         ^~~~~~~~~~~~~~~~~#include <octave/config.h>

         ^~~~~~~~~~~~~~~~~
In file included from galoisfield.cc:21:
./galois.h:24:10: fatal error: 'octave/config.h' file not found
#include <octave/config.h>
         ^~~~~~~~~~~~~~~~~
1 error generated.
1 error generated.
make: *** [galoisfield.o] Error 1
make: *** Waiting for unfinished jobs....
make: *** [galois-def.o] Error 1
1 error generated.
make: *** [galois.o] Error 1

Andrew Janke <apjanke>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by lostbard (Posted a comment)
  • -email is unavailable- added by apjanke (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-12-27 lostbard StatusNone => Duplicate
        Open/ClosedOpen => Closed
        Operating SystemMac OS => Any

    Back to the top


    Powered by Savane 3.5