bugGNU Octave - Bugs: bug #53730, Rectangle corners are not closed,...

 
 

bug #53730: Rectangle corners are not closed, lines do not meet

Submitted by:  Matthias Brennwald <mbrennwa>
Submitted on:  Mon 23 Apr 2018 08:46:40 PM UTC  
 
Category:  Plotting with OpenGL Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  dev Operating System:  Any

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 01 Nov 2018 03:26:34 PM UTC, comment #3: 

Sure.  Closing report since we already have recorded the issue in other bug reports.

Rik <rik5>
Project Administrator
Thu 01 Nov 2018 12:11:58 PM UTC, comment #2: 

@Rik: Can we close this report since it is a duplicate?

Pantxo Diribarne <pantxo>
Project Member
Tue 24 Apr 2018 12:18:17 AM UTC, comment #1: 

Confirmed.  The on-screen problem is known and is a duplicate of parts of bug #39643 and bug #46739.

Rik <rik5>
Project Administrator
Mon 23 Apr 2018 08:46:40 PM UTC, original submission:  

Plotting a rectangle with the FLTK backend results in poor corners. The lines do not meet such that the corner looks nice. On screen, this issue occurs with all four corners. If the plot is saved to a file, the issue only occurs with the lower right corner (see attachment).

Here's some code to illustrate the problem:

rectangle ( 'Position',[ 1 1 2 2] , 'Linewidth',10 )
axis ( [0 4 0 4] )
print ( 'test.png' )

Matthias Brennwald <mbrennwa>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #43998:  test.png added by mbrennwa (11KiB - image/png - Lower right corner is "open")

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by pantxo (Posted a comment)
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by mbrennwa (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 7 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-11-01 rik5 Open/ClosedOpen => Closed
    2018-04-24 rik5 CategoryPlotting => Plotting with OpenGL
        StatusNone => Duplicate
        Release4.2.2 => dev
    2018-04-24 rik5 Dependencies- => Depends on bugs #46739
    2018-04-24 rik5 Dependencies- => Depends on bugs #39643
    2018-04-23 mbrennwa Attached File- => Added test.png, #43998

    Back to the top


    Powered by Savane 3.7