bugGNU Octave - Bugs: bug #52461, "help" subfunctions...

 
 

bug #52461: "help" subfunctions using "filemarker" seems not work

Submitted by:  None
Submitted on:  Mon 20 Nov 2017 02:32:01 AM UTC  
 
Category:  Octave Function Severity:  3 - Normal
Priority:  5 - Normal Item Group:  None
Status:  Duplicate Assigned to:  None
Originator Name:  Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  4.2.1
Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 23 Nov 2017 07:24:52 PM UTC, comment #2: 

I just pushed a change which allows help text for subfunctions to be accessed.  This is available on the development branch here (http://hg.savannah.gnu.org/hgweb/octave/rev/9a1b193ddd01).

Rik <rik5>
Project Administrator
Thu 23 Nov 2017 06:33:21 PM UTC, comment #1: 

This is a duplicate of bug #46008.  Marking as such and closing this report.

Rik <rik5>
Project Administrator
Mon 20 Nov 2017 02:32:01 AM UTC, original submission:  

The docstring of "filemarker" says that

     By default this is the character '>'.  This can be used in a
     generic manner to interact with subfunctions.  For example,

          help (["myfunc", filemarker, "mysubfunc"])

     returns the help string associated with the subfunction 'mysubfunc'
     located in the file 'myfunc.m'.

Now for a file "func1.m"

$  cat func1.m
%% help1
function y = func1 (x)
%% help1.1
  y = func2 (x);
endfunction

%% help2
function y = func2 (x)
%% help2.1
  y = x + 1;
endfunction

and in octave-cli

octave:63>  help func1
'func1' is a function from the file /home/user/func1.m

help1

octave:64>  help func1>func2
error: help: 'func1>func2' is not documented
octave:64>  help func1>foo

help1

octave:65>

Similar results can be got for the following commands (The outputs are too long, so I do not paste them here)

help gallery
help gallery>cauchy
help gallery>foo

Besides, I searched the octave document but does not find the definition about the docstring associated with a subfunction.

It's not a big deal because in reality it seems that we do not use the docstring of a subfunction.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2017-11-23 rik5 CategoryNone => Octave Function
        StatusNone => Duplicate
        Open/ClosedOpen => Closed
    2017-11-23 rik5 Dependencies- => Depends on bugs #46008

    Back to the top


    Powered by Savane 3.6