bugGNU Octave - Bugs: bug #52297, octave exited with signal 11

 
 

bug #52297: octave exited with signal 11

Submitted by:  None
Submitted on:  Fri 27 Oct 2017 03:32:46 PM UTC  
 
Category: GUISeverity: 3 - Normal
Priority: 5 - NormalItem Group: Segfault, Bus Error, etc.
Status: DuplicateAssigned to: None
Originator Name: Originator Email: -email is unavailable-
Open/Closed: ClosedRelease: 4.2.1
Operating System: GNU/Linux

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Wed 21 Mar 2018 01:07:34 AM UTC, comment #7:

I think this is indeed a duplicate of bug #42469. The info in comment #6 leads me to believe that bug #42469 is fixed with Qt 5.

The solution seems to be to use Qt 5 (which will be the case eventually for all users) or to disable autocompletion in the editor.

Mike Miller <mtmiller>
Project Administrator
Tue 07 Nov 2017 03:15:20 PM UTC, comment #6:

Torsten, on my OpenSuse Tumbleweed-pc I have libqscintilla2_qt5-13 (2.10-2.3) and libqscintilla_qt5-devel (2.10-2.3) installed. On my Linux Mint-pc I have libqscintilla2-12v5 (2.9.2+dfsg-3build1) and libqscintilla2-l10n (2.9.2+dfsg-3build1) installed. On both pc's I have fcitx input method installed, but when I work with Octave it is just my keyboard (Germany) activated.

No, when I type '-sign or even if I activate my kyrilic input method - crash does not happens.

Andriano <celentanos>
Sun 05 Nov 2017 09:50:34 AM UTC, comment #5:

Andriano, do you have different versions of QScintilla installed on the two systems or are you using different keyboards?

In addition, does the crash happens when typing ' or other dead letters as described in bug #42469 or also for other inputs?

Torsten <ttl>
Project Member
Fri 03 Nov 2017 08:24:00 AM UTC, comment #4:

Yes, without autocompletion Editor works fine. But on my second pc (OpenSuse Tumbleweed) Editor works fine also with autocompletion. bug # 42469 says that there is an error in Qscintilla (if you use ibus input method). On both computers I use fcitx input method (disabled when working in Octave).

Andriano <celentanos>
Thu 02 Nov 2017 07:51:17 PM UTC, comment #3:

Does the editor work as expected when you disable the autocompletion? If so, this bug seems to be a duplicate of bug #42469.

Torsten <ttl>
Project Member
Thu 02 Nov 2017 08:34:51 AM UTC, comment #2:

I have the same problem. I type in Editor-Window just:

data = abc
data =

and octave crashes with message in terminal: 'octave exited with signal 11'. It happens even if I edit some other m-files. I have Linux Mint 18.2 KDE Edition. Octave installed from: ppa:octave/stable. I think it has something to do with the autocomplete function.

Andriano <celentanos>
Sat 28 Oct 2017 02:42:16 PM UTC, comment #1:

Thank you for the report. I can't reproduce this issue on ubuntu 16.04 LTS with current stable or default branch.

Is the "\" at the end of the input required for the crash? Does this also happen when you try to save the new tab that is automatically opened when the editor comes up with no other file opened?

Torsten <ttl>
Project Member
Fri 27 Oct 2017 03:32:46 PM UTC, original submission:

Distributive: ubuntu 16.04.3
GNU Octave from ppa:octave/stable
Steps for obtaining:
1) File->New->New Script
2) Input some text, for example print('Insert some variable')\
Octave crashes with "octave exited with signal 11" message in console window. If it's not crashes, try to save file and it will crash.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by celentanos (Posted a comment)
  • -email is unavailable- added by ttl (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Wed 21 Mar 2018 01:07:34 AM UTCmtmillerStatusNone=>Duplicate
      Open/ClosedOpen=>Closed
      Dependencies-=>Depends on bugs #42469

    Back to the top


    Powered by Savane 3.1-cleanup1