bugGNU Octave - Bugs: bug #51796, Printing figure fails with...

 
 

bug #51796: Printing figure fails with "empty feedback buffer and/or nothing else to print" message

Submitted by:  None
Submitted on:  Sat 19 Aug 2017 11:11:53 PM UTC  
 
Category:  Octave Function Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Unexpected Error or Warning
Status:  Duplicate Assigned to:  None
Originator Name:  Brad Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  4.2.1
Operating System:  Any

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Tue 06 Mar 2018 01:15:52 PM UTC, comment #6: 

Ok, I could identify this bug as being another manisfestation of bug #40333.

The reason why the "empty feedback buffer ..." appears is that under some circumstances the legend is drawn out of the viewport and gl2ps thus doesn't receive any primitive for the legend.

I'll close this report as a duplicate of bug #40333.

Pantxo Diribarne <pantxo>
Project Member
Wed 28 Feb 2018 04:13:22 PM UTC, comment #5: 

Confirmed. I can reproduce the error, both with 4.2 and dev, with the following simplified script:

close all
graphics_toolkit qt
figure ("position", [0, 0, 400, 400])
plot (1:10, ";foo;")
print -F:14 qt.jpg

The figure position must originate at [0,0] for the warning to appear. Changing the origin to [1,1] eliminates the warning but the output jpg is still wrong.
Reopening report. I'll look into this soon.

Pantxo Diribarne <pantxo>
Project Member
Wed 28 Feb 2018 01:39:19 PM UTC, comment #4: 

I can reproduce the error with Octave 4.2.1 running under Ubuntu 17.10, see attached file.

As far as I could figure out, the error occurs under the following conditions:

1. Either fltk or qt is used as graphic device.
2. The figure command defines the position property.
3. The print command uses the option -Ffontname:size

(file #43418)

Johannes <johannes>
Mon 29 Jan 2018 06:14:21 AM UTC, comment #3: 

I've seen this error when debugging some code, but not in operation.  It had to do with using FLTK toolkit to print when the figure "visible" property is "off".  If I see this error again, I will take note.

Dan Sebald <sebald>
Tue 19 Sep 2017 09:26:36 PM UTC, comment #2: 

Closing report as it is not sufficiently detailed to be reproduced and no further info was provided by the OP after a month.

Pantxo Diribarne <pantxo>
Project Member
Sun 20 Aug 2017 01:42:49 PM UTC, comment #1: 

Trying the script

plot (1:10)
set (gca, 'Position', [0 0 1 1], 'units', 'normalized')
print ("a1.jpg", "-djpeg", "-r0")

With Octave 4.2.1 on Win-10 machine, with qt graphic toolkit, and did not see any problem.

Do you get error on this script?
Can you give some details: What OS, which version of Octave, which graphics toolkit?

Avinoam Kalma <avinoam>
Project Member
Sat 19 Aug 2017 11:11:53 PM UTC, original submission:  

I can generate a figure exactly as I want on the screen. When I issue the print command the figure goes blank and I get the following messages to the screen.

warning: gl2ps_renderer::draw_axes: empty feedback buffer and/or nothing else to print
warning: called from
    _opengl_print_ at line 169 column 7

Sorry don't know how to produce this error with a small code snippet but the offending commands are:

set (gca, 'Position', [0 0 1 1], 'units', 'normalized')
print (prntname, "-djpeg", "-r0")

If I comment out the set command it works as expected. Unfortunately it doesn't produce the image I need.

I've seen many bug reports that seem to reference a similar problem, but I haven't been able to figure out the fix. Apologies as I'm a high level user so get lost when asked to compile bug patches.

Thanks!

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #43418:  bug.m added by johannes (758B - text/x-objcsrc)

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by johannes (Updated the item)
  • -email is unavailable- added by sebald (Posted a comment)
  • -email is unavailable- added by jwe (Updated the item)
  • -email is unavailable- added by pantxo (Updated the item)
  • -email is unavailable- added by avinoam (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 10 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-03-06 pantxo StatusConfirmed => Duplicate
        Open/ClosedOpen => Closed
        Dependencies- => Depends on bugs #40333
    2018-02-28 pantxo Open/ClosedClosed => Open
        Operating SystemMicrosoft Windows => Any
    2018-02-28 pantxo StatusNeed Info => Confirmed
    2018-02-28 johannes Attached File- => Added bug.m, #43418
    2017-09-19 pantxo Open/ClosedOpen => Closed
    2017-08-30 jwe SummaryPrint => Printing figure fails with "empty feedback buffer and/or nothing else to print" message
    2017-08-21 pantxo StatusNone => Need Info

    Back to the top


    Powered by Savane 3.5