bugGNU Octave - Bugs: bug #50676, CTD when writing Latin accents on...

 
 

bug #50676: CTD when writing Latin accents on the editor (e.g. "â", "ã")

Submitted by:  Gabriel <r00t>
Submitted on:  Thu 30 Mar 2017 03:26:23 AM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Segfault, Bus Error, etc.
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  4.0.3 Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 30 Mar 2017 05:46:56 AM UTC, comment #4: 

Thanks for testing. This looks like a duplicate of bug #42469.

Torsten Lilge <ttl>
Project Member
Thu 30 Mar 2017 05:35:42 AM UTC, comment #3: 

Does not crash with autocomplete disabled! To be more specific, it's the auto-complete list that causes the crash (Edit > Preferences > Editor > Auto-complete > Automatically exhibit auto-complete list).

I use 4.0.3 because it is the one on Fedora repo (octave-6:4.0.3-1.fc25).

Thanks for the response.

Gabriel <r00t>
Thu 30 Mar 2017 05:09:53 AM UTC, comment #2: 

Does the crash also occur when you disable the autocompletion?

Torsten Lilge <ttl>
Project Member
Thu 30 Mar 2017 03:49:22 AM UTC, comment #1: 

Works for me with 4.2.1.
(4.0.3 is old and unmaintained).

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Thu 30 Mar 2017 03:26:23 AM UTC, original submission:  

On Octave's editor, writing "â" makes Octave crash to desktop (no error message given).

How to reproduce:
1. Open Octave;
2. Go to the editor tab;
3. Write the following:
   distâ
As soon as you write the "â" character, Octave will crash.

NOTE: writing just an "â" (as the first character) or several of them doesn't result in a crash. Other characters instead of "dist" also result in a crash, when followed by "â" or other Latin-accents (e.g. "ã"). Seems to only crash after an specific number of characters before the accentuated one.

Writing the accent character before the rest of the word DOES NOT result in a crash, e.g.:
1. Write "â" in the editor;
2. Move the cursor before the letter;
3. Write "dist";
4. Move the cursor to the end of the line;
5. Write anything.
No crashes will occur, HOWEVER, if you write any accent after that, it will crash.

Gabriel <r00t>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by ttl (Posted a comment)
  • -email is unavailable- added by dasergatskov (Posted a comment)
  • -email is unavailable- added by r00t (Submitted the item)
  • -email is unavailable- added by r00t
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2017-03-30 ttl Dependencies- => Depends on bugs #42469
    2017-03-30 ttl StatusNone => Duplicate
        Open/ClosedOpen => Closed
    2017-03-30 r00t Carbon-Copy- => Added r00t

    Back to the top


    Powered by Savane 3.5