bugGNU Octave - Bugs: bug #50453, image package does not compile...

 
 

bug #50453: image package does not compile with dev

Submitter:  A.R. Burgers <arb>
Submitted:  Sat 04 Mar 2017 10:03:25 AM UTC
 
Category:  Interpreter Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Regression
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  * Closed
Release:  * dev Operating System:  * Any
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Sat 04 Mar 2017 11:18:44 AM UTC, comment #1: 

Duplicate of bug #50180

Philip Nienhuis <philipnienhuis>
Project Member
Sat 04 Mar 2017 10:03:25 AM UTC, original submission:  

Compilation of the image package gives errors as below.
Maybe because the image package is "using namespace octave::image"

octave:2> pkg install -forge image
strel.cc: In constructor 'octave::image::strel::strel(const octave_value&)':
strel.cc:52:38: error: call of overloaded 'feval(const char [6], octave_value_list&)' is ambiguous
       se = feval ("strel", strel_args)(0);
                                      ^
strel.cc:52:38: note: candidates are:
In file included from strel.cc:27:0:
$HOME/x86_64/include/octave-4.3.0+/octave/parse.h:550:3: note: octave_value_list octave::feval(const string&, const octave_value_list&, int)
   feval (const std::string& name,
   ^
$HOME/x86_64/include/octave-4.3.0+/octave/parse.h:635:1: note: octave_value_list feval(const string&, const octave_value_list&, int)
 feval (const std::string& name,

A.R. Burgers <arb>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by arb (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2017-03-05 avinoam Dependencies- Depends on bugs #50180
    2017-03-04 philipnienhuis StatusNone Duplicate
        Open/ClosedOpen Closed
        Operating SystemGNU/Linux Any

    Back to the top


    Powered by Savane 3.9