bugGNU Octave - Bugs: bug #50180, OF-image fails to build with dev...

 
 

bug #50180: OF-image fails to build with dev Octave (4.3.0+)

Submitted by:  Philip Nienhuis <philipnienhuis>
Submitted on:  Sun 29 Jan 2017 05:30:18 PM UTC  
 
Category: Octave Forge PackageSeverity: 3 - Normal
Priority: 5 - NormalItem Group: Build Failure
Status: FixedAssigned to: None
Originator Name: philipnienhuisOpen/Closed: Closed
Release: devOperating System: Any

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Mon 14 Aug 2017 03:26:16 PM UTC, comment #14:

Thanks for all the help. I think I'm straightened out now and it's all working.

Jared Sorensen <gnolaum>
Sat 12 Aug 2017 11:59:33 PM UTC, comment #13:

> Newbie here; I installed octave from source because I'm on CentOS,


If you have this error, you did not install an Octave release. Instead, you installed the current development sources, an in between release. Unless you need some of in the development features, you should uninstall Octave and build from source one of the Octave releases. One of these ftp://ftp.gnu.org/gnu/octave/

Carnë Draug <carandraug>
Project Member
Sat 12 Aug 2017 06:51:21 PM UTC, comment #12:

The current development branch of the image package builds and runs for me with Octave 3.8.2, 4.0.3, 4.2.1, and Octave's default branch, so this bug is indeed resolved.

Newbie - if you need help, this is not the right forum to ask for help, try asking on the help mailing list (see https://www.octave.org/support).

Mike Miller <mtmiller>
Project Administrator
Sat 12 Aug 2017 05:55:44 PM UTC, comment #11:

Assuming you have mergcurial (hg) download the current dev repo:

hg clone http://hg.code.sf.net/p/octave/image

cd image

make dist

There should now be a tarball in the target directory that may install in octave.

John Donoghue <lostbard>
Project Member
Sat 12 Aug 2017 01:25:10 AM UTC, comment #10:

Newbie here; I installed octave from source because I'm on CentOS, which only supports octave 3.8.2 currently. I want to use something from the image package, which requires an update. Then when I tried to install the image package, I got the error being talked about here. It's not clear to me how to resolve this error. Can someone give me some instructions to follow so I can get past this error and begin to use the image package? Thanks-

Jared Sorensen <gnolaum>
Wed 15 Mar 2017 10:35:03 PM UTC, comment #9:

> What about the patch in MXE-octave
> (http://hg.octave.org/mxe-octave/rev/74c7af6a36c0),
> should it be there after your fix?


Yes, because mxe installs the last release of a package. It wouldn't if I backported the fix into the image package stable branch and made a new release 2.6.2.

Carnë Draug <carandraug>
Project Member
Wed 15 Mar 2017 07:31:24 PM UTC, comment #8:

Thanks, Carnë.

What about the patch in MXE-octave
(http://hg.octave.org/mxe-octave/rev/74c7af6a36c0),
should it be there after your fix?

Avinoam Kalma <avinoam>
Project Member
Wed 15 Mar 2017 05:43:25 PM UTC, comment #7:

> I am not sure if applying this patch to OF-image would stop OF-image to work with stable Octave.


Yes it would.

---

I made a wrapper header for the core functions that change place and added a configure check. Seems to work for me, both 4.2.1 and development sources.

http://hg.code.sf.net/p/octave/image/rev/742462d332ad

I am not thinking of applying this to the stable branch since I hope that image 2.8 is out by the time 4.4 is out. I would also guess that anyone building octave from development sources should be also be building the image package from source and not installing the last release. This might be misguided so let's see if anyone complains.

Carnë Draug <carandraug>
Project Member
Sun 12 Mar 2017 08:31:03 PM UTC, comment #6:

"it" in the second paragraph refers to the original patch (file #39964)

Philip Nienhuis <philipnienhuis>
Project Member
Sun 12 Mar 2017 08:29:23 PM UTC, comment #5:

The namespace change that induced this bug was made on Octave's development branch, not on stable. I am not sure if applying this patch to OF-image would stop OF-image to work with stable Octave.

BTW looking at JWE's patch:
Yesterday I applied it to my local tree as well (and I can confirm of-image gets built) but I also had to register the patch in dist-files.mk to get it picked up by the build system.

Philip Nienhuis <philipnienhuis>
Project Member
Sat 11 Mar 2017 03:36:59 PM UTC, comment #4:

This patch fixes the problem, and it was applied by JWE to
the mxe tree (http://hg.octave.org/mxe-octave/rev/74c7af6a36c0).

Shouldn't the patch by applied to the image package itself
(http://hg.code.sf.net/p/octave/image)?

Avinoam Kalma <avinoam>
Project Member
Fri 10 Mar 2017 04:17:51 PM UTC, comment #3:

The attached patch will avoid the problem with the call to feval being ambiguous.

(file #39964)

John W. Eaton <jwe>
Project Administrator
Wed 01 Feb 2017 06:56:02 PM UTC, comment #2:

cc'd package maintainer

Philip Nienhuis <philipnienhuis>
Project Member
Mon 30 Jan 2017 04:15:21 PM UTC, comment #1:

Confirmed on Windows running MXE-Octave with hg_id 868daa374c49

Avinoam Kalma <avinoam>
Project Member
Sun 29 Jan 2017 05:30:18 PM UTC, original submission:

On Linux I get:

On Windows, both while cross-building or later on when 4.3.0+ has been installed, I get similar error messages.
From the mxe-octave build log:

hg id Octave: 9241a0fa7873 tip "Additional output arguments for fminsearch (bug #44220)."

Philip Nienhuis <philipnienhuis>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #39964:  image-diffs.txt added by jwe (3KiB - text/plain)

 

Depends on the following items: None found

Digest:
   bug dependencies.

 

Carbon-Copy List
  • -unavailable- added by mtmiller (Posted a comment)
  • -unavailable- added by lostbard (Posted a comment)
  • -unavailable- added by gnolaum (Posted a comment)
  • -unavailable- added by jwe (Updated the item)
  • -unavailable- added by philipnienhuis
  • -unavailable- added by avinoam (Posted a comment)
  • -unavailable- added by philipnienhuis (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 8 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Wed 15 Mar 2017 05:43:25 PM UTCcarandraugStatusPatch Reviewed=>Fixed
      Open/ClosedOpen=>Closed
    Sat 11 Mar 2017 03:36:59 PM UTCavinoamStatusPatch Submitted=>Patch Reviewed
    Fri 10 Mar 2017 05:02:27 PM UTCavinoamStatusConfirmed=>Patch Submitted
    Fri 10 Mar 2017 04:17:51 PM UTCjweAttached File-=>Added image-diffs.txt, #39964
    Sun 05 Mar 2017 07:35:15 PM UTCavinoamDependencies-=>bugs #50453 is dependent
    Wed 01 Feb 2017 06:56:02 PM UTCphilipnienhuisCarbon-Copy-=>Added carandraug
    Mon 30 Jan 2017 04:15:21 PM UTCavinoamStatusNone=>Confirmed

    Back to the top


    Powered by Savane 3.1-cleanup1