bugXBoard - Bugs: bug #48571, Error after selecting new engine.

 
 

bug #48571: Error after selecting new engine.

Submitter:  Giorgos Kostopoulos <giorgos67>
Submitted:  Wed 20 Jul 2016 02:59:21 PM UTC
 
Category:  XBoard (GTK version) Severity:  3 - Normal
Item Group:  Crash Status:  Invalid
Assigned to:  None Open/Closed:  Closed
Release:  None
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       No canned response available

 

Sat 15 May 2021 02:38:40 AM UTC, comment #4: 

Since the OP himself said this report is invalid, I'm closing it as invalid.

Tim Mann <mann>
Project Administrator
Thu 21 Jul 2016 02:44:40 PM UTC, comment #3: 

Since (as the attached log indicates) this is a gnuchess bug, this report is invalid (I think).
Sorry!!! :-)
G.

Giorgos Kostopoulos <giorgos67>
Thu 21 Jul 2016 11:10:27 AM UTC, comment #2: 

I'm on a fresh Debian installation. No previous or multiple instances of xboard or gnuchess.

(file #37971)

Giorgos Kostopoulos <giorgos67>
Wed 20 Jul 2016 11:14:17 PM UTC, comment #1: 

I looked again at it and here's what I realized:

I went to the Konsole and I gave "export LANG=C" (for switching
Konsole interface -> English).
The I gave "xboard" and indeed XBoard loaded in memory successfully
and informed me that couldn't load fairymax.
Well...fair enough that couldn't find fairymax, because I don't have it installed. :-)

Then I loaded GNU Chess as the 1st (or the 2nd) engine, without any crash or error message.
Problem solved for the moment.

Then I returned my Konsole to my mother language (Greek) again (giving "export LANG=el_GR.UTF-8") and I retried. The problem remains and XBoard keeps crashing while loading GNU Chess.

Seems the problem is happening at non-English locales???
G.

Giorgos Kostopoulos <giorgos67>
Wed 20 Jul 2016 02:59:21 PM UTC, original submission:  

Hi! :-)

After going Engine -> Load new 1st engine -> (Load 1st engine window) -> Selecting GNU Chess here (providing or not the Engine Directory) -> OK,
Xboard brings up a window, with the error message: "Error writing to first chess program: Broken pipe" and the OK button.
Pressing "OK" aborts the program.

The workaround is launching the preferred engine with command line arguments. Eg. making a launcher with the command "xboard -fcp gnuchess -scp gnuchess". The downside is that you can't change engine on the fly. (you have to close XBoard and relaunch it, with the new engine).

My system is Debian Jessie x64 KDE and XBoard v.4.9.0. GNU Chess v.6.2.2. Both XBoard and GNU Chess, compiled locally.

Bye! :-)
G.

Giorgos Kostopoulos <giorgos67>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #37971:  xboard.debug added by giorgos67 (5KiB - application/octet-stream)
file #37956:  XBOARD.png added by giorgos67 (7KiB - image/png - Screenshot with the error messsage.)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mann (Posted a comment)
  • -email is unavailable- added by giorgos67 (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2021-05-15 mann StatusNone Invalid
        Open/ClosedOpen Closed
    2016-07-21 giorgos67 Attached File- Added xboard.debug, #37971
    2016-07-20 giorgos67 Attached File- Added XBOARD.png, #37956

    Back to the top


    Powered by Savane 3.9