bugGNU Wget - Bugs: bug #48502, Segfault when trying to use WGET

 
 

bug #48502: Segfault when trying to use WGET

Submitted by:  None
Submitted on:  Wed 13 Jul 2016 08:23:05 PM UTC  
 
Category:  Crash/Freeze/Infloop Severity:  3 - Normal
Priority:  5 - Normal Status:  None
Privacy:  Public Assigned to:  None
Originator Name:  fulopm Originator Email:  -email is unavailable-
Open/Closed:  Open Release:  1.17.1
Operating System:  GNU/Linux Reproducibility:  Every Time
Fixed Release:  None Planned Release:  None
Regression:  None Work Required:  None
Patch Included:  None

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Fri 30 Sep 2016 07:39:20 PM UTC, comment #5:

Could you please try with --progress=dot and report back ?

Tim Ruehsen <rockdaboot>
Project Administrator
Fri 30 Sep 2016 04:27:12 PM UTC, comment #4:

I can reproduce the SIGSEGV with the URL provided in the screenshot, on ubuntu 16.04 (wget version 1.17.1-1ubuntu1.1):

wget https://brave-download.global.ssl.fastly.net/multi-channel/releases/dev/0.11.0/debian64/brave_0.11.0_amd64.deb

but not on Fedora 24's wget (1.18-1.fc24).

This suggests that the problem might lie in the Ubuntu-16.04-specific version or patches.

2) I also get SIGSEGV on 16.04 with this, and cannot reproduce it on fedora 24, does it have the same root cause?

wget http://mirror3.mirror.garr.it/mirrors/eclipse/technology/epp/downloads/release/neon/1/eclipse-committers-neon-1-linux-gtk-x86_64.tar.gz

Salvatore Vitale <vitsvitt>
Tue 26 Jul 2016 12:49:39 PM UTC, comment #3:

Could you try with a different locale, e.g. like

$ LC_ALL=C wget <your URL>

Because, basically wget works on Ubuntu. There could be something special with your environment.

Tim Ruehsen <rockdaboot>
Project Administrator
Thu 14 Jul 2016 07:40:47 PM UTC, comment #2:

-Computer-
Processor : 2x Intel(R) Pentium(R) CPU P6200 @ 2.13GHz
Memory : 2937MB (2146MB used)
Operating System : Ubuntu 16.04 LTS
-Display-
Resolution : 1366x768 pixels
OpenGL Renderer : Unknown
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : HDA-Intel - HDA Intel MID
-Input Devices-
Lid Switch
Power Button
Power Button
AT Translated Set 2 keyboard
Video Bus
Logitech USB Receiver
Logitech USB Receiver
SynPS/2 Synaptics TouchPad
Toshiba input device
HDA Intel MID Mic
HDA Intel MID Headphone
USB Camera
OM
-Printers-
No printers found
-SCSI Disks-
ATA Hitachi HTS54503
TSSTcorp CDDVDW TS-L633C

fulopm <fulopm>
Thu 14 Jul 2016 06:02:02 AM UTC, comment #1:

can you give the machine details, which you ran this on?

ramki <kothamasu>
Wed 13 Jul 2016 08:23:05 PM UTC, original submission:

I get segmentation fault when I try to use wget (screenshot included). Remark: the Hungarian output message means segmentation fault (core dumped)

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #37862:  2016-07-13-221926_1366x768_scrot.png added by None (217KiB - image/png)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by vitsvitt (Posted a comment)
  • -email is unavailable- added by rockdaboot (Posted a comment)
  • -email is unavailable- added by fulopm (Posted a comment)
  • -email is unavailable- added by kothamasu (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

     

     

    Follows 1 latest change.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-07-13 None Attached File- => Added 2016-07-13-221926_1366x768_scrot.png, #37862

    Back to the top


    Powered by Savane 3.3