bugGNU Octave - Bugs: bug #47165, Crash when setting breakpoint in...

 
 

bug #47165: Crash when setting breakpoint in @ftp/ftp via GUI

Submitted by:  Rik <rik5>
Submitted on:  Tue 16 Feb 2016 12:01:44 AM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Segfault, Bus Error, etc.
Status:  Fixed Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  dev Operating System:  Microsoft Windows

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Fri 26 Feb 2016 05:02:19 PM UTC, comment #5: 

My bad.  When I reported this I put down the Windows O/S, but I think I did the original testing on Linux.  The bug is gone from Linux and that is good enough for me right now.  It can be re-opened if someone encounters it on Windows, but I'm pretty sure it has been cleared.

Rik <rik5>
Project Administrator
Fri 26 Feb 2016 02:32:30 PM UTC, comment #4: 

Torsten has pushed the patches that fix this on Linux and I believe also fix it on Windows.  Since I can't easily test on Windows, I'll leave this as "ready for test on Windows".

Lachlan Andrew <lachlan>
Tue 16 Feb 2016 11:01:02 AM UTC, comment #3: 

This bug (or one of its related apparitions) is still valid for Windows systems, see bug #46795 and esp. comment #79. Torsten is working on it.
So let's wait until that is finally fixed.

Philip Nienhuis <philipnienhuis>
Project Member
Tue 16 Feb 2016 05:34:18 AM UTC, comment #2: 

@Lachlan: The patch you suggested does stop the segfault.  I'll let Torsten review and then maybe this bug can be closed.

Rik <rik5>
Project Administrator
Tue 16 Feb 2016 02:04:32 AM UTC, comment #1: 

Rik, this may be related to a bug I introduced, which is fixed by file #36310 at bug #46795.  That bug causes a crash whenever a breakpoint is created for a file that is not on the path or in the current directory, when Octave tries to prompt to put it on the path.

I had a couple of less elegant attempts that Torsten gave feedback on, but I haven't heard any negative feedback on file #36310.

Lachlan Andrew <lachlan>
Tue 16 Feb 2016 12:01:44 AM UTC, original submission:  

The GUI exits with signal 6 when an attempt is made to set a breakpoint in an old-style class function.

Steps to reproduce:

./run-octave -f
edit @ftp/ftp
# Use mouse to select line 50
# Use "Toggle Breakpoint" from menubar

Rik <rik5>
Project Administrator

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by lachlan (Posted a comment)
  • -email is unavailable- added by lachlan
  • -email is unavailable- added by rik5 (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 6 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-02-26 rik5 StatusReady For Test => Fixed
        Open/ClosedOpen => Closed
    2016-02-26 lachlan StatusNone => Ready For Test
        Operating SystemGNU/Linux => Microsoft Windows
    2016-02-16 lachlan Carbon-Copy- => Added ttl
    2016-02-16 rik5 Dependencies- => Depends on bugs #41514

    Back to the top


    Powered by Savane 3.5