bugGNU GRUB - Bugs: bug #46032, TPM support

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #46032: TPM support

Submitted by:  Mateus Baptista <madruga>
Submitted on:  Wed 23 Sep 2015 04:32:32 AM UTC  
 
Category:  Booting Severity:  Major
Priority:  5 - Normal Item Group:  Feature Request
Status:  Wont Fix Privacy:  Public
Assigned to:  None Originator Name: 
Open/Closed:  Closed Release: 
Release:  2.02~beta1 Reproducibility:  None
Planned Release:  None

Wed 21 Mar 2018 09:07:39 PM UTC, comment #3: 

I would also interested to know why TPM support is incompatible with GNU policies. CoreOS has forked GRUB and added TPM2.0 support in addition to the TPM1.2 support included in trustedgrub described below. I think it is clear that there is a demand for this feature.

https://github.com/coreos/grub

Andrew DiPrinzio <ajd394>
Fri 17 Feb 2017 07:06:37 PM UTC, comment #2: 

Which specific GNU policy would this violate?

jbash aka John Bashinski <jbash>
Wed 07 Oct 2015 09:21:17 PM UTC, comment #1: 

Against GNU policies.

Vladimir Serbinenko <phcoder>
Project Administrator
Wed 23 Sep 2015 04:32:32 AM UTC, original submission:  

Hello everyone,

Some time ago many feature requests about TPM support were closed because FSF considered them dangerous[1,2,3].

In 2015 RMS declared TPM are not dangerous[4] ("...the “Trusted Platform Modules” available for PCs are not dangerous, and there is no reason not to include one in a computer or support it in system software."), so I think it's eligible now to ask this feature again.

It was actually implemented in a GRUB fork[5] so the effort of implementing this feature is just a merge of code already written.

Thanks

[1] http://lists.gnu.org/archive/html/bug-grub/2012-07/msg00017.html
[2] http://lists.gnu.org/archive/html/grub-devel/2009-02/msg00217.html
[3] http://lists.gnu.org/archive/html/grub-devel/2009-08/msg00407.html
[4] http://www.gnu.org/philosophy/can-you-trust.en.html
[5] http://sourceforge.net/projects/trustedgrub/

Mateus Baptista <madruga>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by ajd394 (Posted a comment)
  • -email is unavailable- added by jbash (Posted a comment)
  • -email is unavailable- added by phcoder (Posted a comment)
  • -email is unavailable- added by madruga (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-11-08 phcoder Open/ClosedOpen => Closed
    2015-10-07 phcoder StatusNone => Wont Fix

    Back to the top


    Powered by Savane 3.6