bugGNU Octave - Bugs: bug #45852, GUI doc browser should also work...

 
 

bug #45852: GUI doc browser should also work for forge packages

Submitted by:  Hartmut <hardy>
Submitted on:  Mon 31 Aug 2015 08:11:31 PM UTC  
 
Category:  GUI Severity:  1 - Wish
Priority:  1 - Later Item Group:  Feature Request
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  dev Operating System:  Any

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 19 Jan 2019 10:29:25 AM UTC, comment #2: 

There's been some progress on this. See bug #44529.

Maybe this could be closed as a dupe of bug #44529? Seems like they're asking for the same thing, and there's more active discussion over there.

Andrew Janke <apjanke>
Fri 11 Sep 2015 11:51:39 AM UTC, comment #1: 

Thanks for your feature request. Any help you could provide towards making this happen would be very welcome.

There are several blockers to overcome before even looking at making the GUI show docs for packages.

First, a common interface for accessing docs of Forge packages (when they provide them) through the doc function, see patch #8491.

Second, maybe integrating the core "doc" function with the "pkg doc" function added in patch #8491. This would require some thought and design work.

Third, not all packages provide their help functions in a Texinfo manual that the doc function can use. What should "doc imerode" do if the image package only provides help strings but not a fully formatted manual?

Mike Miller <mtmiller>
Project Administrator
Mon 31 Aug 2015 08:11:31 PM UTC, original submission:  

This is a feature request for the doc/help browser in the Octave GUI:

The help browser currently shows the help texts to all Octave core functions. I would like to suggest that is also shows the help texts of all LOADED FORGE PACKAGES. For example I would like to see the following to work:

pkg load image
doc imerode

Currently the help texts for the Octave core functions are usually accessed in a different way (i.e. via the doc browser, because it's more convinient) than the Forge package functions (i.e. via the help command on the text console). This split approach is hard to explain to students where I use Octave to teach a special topic that heavily relies on an Octave forge package (the image package in my case).

I do not know how hard this is to implement. But this feature would extend the usefulness of the already existing GUI doc browser beyond the core functions to the whole of Octave forge packages :)

Hartmut <hardy>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by siko1056 (Updated the item)
  • -email is unavailable- added by apjanke (Posted a comment)
  • -email is unavailable- added by hardy (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 8 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-01-20 siko1056 StatusPostponed => Duplicate
        Open/ClosedOpen => Closed
    2019-01-20 siko1056 Dependencies- => Depends on bugs #44529
    2019-01-19 mtmiller Carbon-CopyRemoved 80942 => -
    2015-09-11 mtmiller Severity3 - Normal => 1 - Wish
        Priority5 - Normal => 1 - Later
        StatusNone => Postponed
        Release4.0.0 => dev

    Back to the top


    Powered by Savane 3.6