bugGNU Octave - Bugs: bug #45851, Dot plot inaccurate

 
 

bug #45851: Dot plot inaccurate

Submitter:  None
Submitted:  Mon 31 Aug 2015 08:11:05 PM UTC
 
Category:  Plotting with OpenGL Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Inaccurate Result
Status:  Duplicate Assigned to:  None
Originator Name:  Pablo Creades Originator Email:  -email is unavailable-
Open/Closed:  * Closed Release:  * 3.8.2
Operating System:  * GNU/Linux
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Mon 31 Aug 2015 08:19:58 PM UTC, comment #1: 

Thanks for investigating and reporting a simple test case. This is yet another example of a known problem with the OpenGL-based plotting that Octave implements.

You've identified the possible workarounds for now, use gnuplot or scale the data so it has fewer significant digits.

Mike Miller <mtmiller>
Project Administrator
Mon 31 Aug 2015 08:11:05 PM UTC, original submission:  

I've noticed that when the X data is floating point with lots of decimals, the line and dotted line plots generated using "fltk" are misaligned, and even worst, the lines and dots moves randomly as you resize the plot window.
This behavior is not exhibited when using "gnuplot".
Here is a simple piece of code that would reproduce the error:

plot([7777777.0, 7777777.1], [1,2], ".-")

I found the problem when trying to plot time series in which the x axis contain the date as the number of days since January 1st 0000, as returned by the function "datenum".

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Posted a comment)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-08-31 mtmiller StatusNone Duplicate
        Open/ClosedOpen Closed
        Dependencies- Depends on bugs #32980

    Back to the top


    Powered by Savane 3.9