bugGNU Octave - Bugs: bug #45271, Incorect lineplot when x axis...

 
 

bug #45271: Incorect lineplot when x axis values become large

Submitter:  None
Submitted:  Sun 07 Jun 2015 08:36:32 AM UTC
 
Category:  Plotting Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  Duplicate Assigned to:  None
Originator Name:  Lars Originator Email:  -email is unavailable-
Open/Closed:  * Closed Release:  * 3.8.2
Operating System:  * GNU/Linux
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Sun 07 Jun 2015 03:50:21 PM UTC, comment #3: 

Yes, confirmed. Closing as a duplicate of bug #32980.

Mike Miller <mtmiller>
Project Administrator
Sun 07 Jun 2015 03:48:17 PM UTC, comment #2: 

Probably right, this is a problem in fltk, because

graphics_toolkit("gnuplot")

does produce a correct plot.

Imho, this is a severe problem, because all plots using calendar dates on x axis will fail...

Anonymous
Sun 07 Jun 2015 01:57:13 PM UTC, comment #1: 

probably duplicate of bug #32980

Anonymous
Sun 07 Jun 2015 08:36:32 AM UTC, original submission:  

%Bug in plot() with lines in Octave 3.8.2
%not tested in Octave 4 yet

x = 0 : 1/1440 : 1;
y = rand(size(x));

figure(1);plot(x    ,y,'.-') %all is fine
figure(2);plot(x+now,y,'.-') %yuck....

% dots / markers are always located fine
% but lines are drawn incorrectly when x-values get too big
% probably some rounding or casting problem in plot...
% this happens always when x-axis is a time axis
% as the current time as deliverd by now() triggers the problem  

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-06-07 mtmiller StatusNone Duplicate
        Open/ClosedOpen Closed
        Dependencies- Depends on bugs #32980

    Back to the top


    Powered by Savane 3.9