bugGNU Octave - Bugs: bug #45055, [octave forge] (splines) bin_value...

 
 

bug #45055: [octave forge] (splines) bin_value unit test fails

Submitted by:  Rafael Laboissiere <rlaboiss>
Submitted on:  Fri 08 May 2015 01:16:28 PM UTC  
 
Category:  Octave Forge Package Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Regression
Status:  None Assigned to:  None
Originator Name:  Open/Closed:  Open
Release:  4.0.0 Operating System:  Any

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun 01 Jan 2017 06:54:19 PM UTC, comment #5: 

yes

Nir Krakauer <nir_krakauer>
Wed 28 Dec 2016 10:09:25 PM UTC, comment #4: 

Do I understand comment #3 correctly, that this bug report can be closed as FIXED?

Hartmut <hardy>
Tue 02 Jun 2015 05:40:50 PM UTC, comment #3: 

I found the problem. Built-in var(1) returns NaN, but the version in the nan package returns 0. I fixed the test so that it passes regardless.

Nir Krakauer <nir_krakauer>
Tue 02 Jun 2015 04:10:41 PM UTC, comment #2: 

Retagging release to 4.0.0.

John W. Eaton <jwe>
Project Administrator
Fri 08 May 2015 02:53:26 PM UTC, comment #1: 

Interesting. The reason for my commit 496daa7 is that the test was failing in Octave 3.8, and now passes (in 3.8). I wonder what happened to change Inf vs. NaN being generated in 3.8 vs. 4.0

Nir Krakauer <nir_krakauer>
Fri 08 May 2015 01:16:28 PM UTC, original submission:  

The unit test for the bin_value function fails for the new released version 1.2.8 of the splines package (I am using Octave 4.0.0-rc4 and did not test it with previous versions):

octave:1> pkg load splines
octave:2> test bin_values
***** assert (w_bin, [NaN NaN; 3 1]);
!!!!! test failed
ASSERT errors for:  assert (w_bin,[NaN, NaN; 3, 1])

  Location  |  Observed  |  Expected  |  Reason
   (1,1)         Inf          NaN        'NaN' mismatch
   (1,2)         Inf          NaN        'NaN' mismatch
shared variables
  scalar structure containing the fields:

    x =

       1
       2
       2
       3
       4

    y =

         0     0
         1     1
         2     1
         3     4
         5   NaN

    x_bin =

       1.0000
       2.3333

    y_bin =

       0   0
       2   2

    w_bin =

       Inf   Inf
         3     1

    n_bin =

       1
       3

It worked in version 1.2.7.  Reverting the commit 496daa7 fixes the problem.

Rafael Laboissiere <rlaboiss>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by hardy (Posted a comment)
  • -email is unavailable- added by jwe (Posted a comment)
  • -email is unavailable- added by nir_krakauer (Posted a comment)
  • -email is unavailable- added by rlaboiss (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2017-08-13 jwe Summarysplines: bin_value unit test fails => [octave forge] (splines) bin_value unit test fails
    2015-06-02 jwe Releaseother => 4.0.0

    Back to the top


    Powered by Savane 3.5