bugGNU Octave - Bugs: bug #45026, Control key shortcuts not working...

 
 

bug #45026: Control key shortcuts not working or configurable in Hebrew locale

Submitted by:  Avinoam Kalma <avinoam>
Submitted on:  Tue 05 May 2015 03:14:47 PM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  Need Info Assigned to:  None
Originator Name:  Avinoam Open/Closed:  Open
Release:  4.0.2 Operating System:  Microsoft Windows

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Tue 05 Sep 2017 11:36:51 AM UTC, comment #23:

also happened to me. windows 10 with version 4.2.1

manualy changed to default and got fixed.

could it be that the program try to import local shortcuts and at the same time can't read hebrew charcters leaving all the shortcuts as ctrl+

Anonymous
Wed 21 Sep 2016 01:20:56 PM UTC, comment #22:

I also have the same problem in windows 7 release 4.0.3

Anonymous
Wed 14 Sep 2016 06:27:51 AM UTC, comment #21:

Happened also in Windows 10.
Solved by switching to en_US and manually accepting default shortcuts in preferences.

Joshua Golbert <josh_g>
Wed 25 May 2016 04:20:11 PM UTC, comment #20:

We have another reporter of the same problem, also on Windows in the Hebrew locale, so confirmed as a real bug, but still need someone to identify what's going on here.

Mike Miller <mtmiller>
Project Administrator
Thu 24 Mar 2016 10:02:22 AM UTC, comment #19:

I have check this issue again with 4.0.1 release.
The behavior is the same in these two computers: all the
shortcuts are not working.

see the attached screenshot

(file #36743)

Avinoam Kalma <avinoam>
Project Member
Mon 21 Mar 2016 07:12:51 PM UTC, comment #18:

So according to comment #16, this is not reproducible since it works fine on another Windows 7 system. No further details in several months. Is this a local configuration problem or something that Octave needs to address?

Mike Miller <mtmiller>
Project Administrator
Tue 02 Jun 2015 04:52:27 PM UTC, comment #17:

Retagging release from 4.0.0-rc4 to 4.0.0.

John W. Eaton <jwe>
Project Administrator
Mon 25 May 2015 07:20:07 PM UTC, comment #16:

Yes, Octave doesn't work in Hebrew locale, but this is not
a real problem, because changimg the language in the preference to
"en_US" makes it work.

The problem is that the control keys are not working in the editor.

Strangely enough, like in https://savannah.gnu.org/bugs/index.php?44806, commment #7, on another hebrew Win7 machine the cntrol key DO work.

Avinoam Kalma <avinoam>
Project Member
Mon 25 May 2015 03:48:26 PM UTC, comment #15:

So is the true problem that Octave doesn't work in a Hebrew locale? I'm not sure that the GUI is set up to handle right-to-left text either.

Rik <rik5>
Project Administrator
Mon 25 May 2015 08:45:26 AM UTC, comment #14:

The default language is Hebrew.
I have changed it to En_US.

Avinoam Kalma <avinoam>
Project Member
Fri 22 May 2015 10:28:19 AM UTC, comment #13:

what language did it default to, and what language did you change it to?

John Donoghue <lostbard>
Project Member
Wed 13 May 2015 10:01:58 AM UTC, comment #12:

If I do not change the language, the shortcut section remains
empty, but the behavior is the same.

Avinoam Kalma <avinoam>
Project Member
Tue 12 May 2015 07:55:56 PM UTC, comment #11:

Not exactly. I have started octave, entrered the setting dialog,
changed the language and then exit octave.

Avinoam Kalma <avinoam>
Project Member
Tue 12 May 2015 04:53:09 AM UTC, comment #10:

Did you only start octave (welcome screen, creation of standard settings file) and exit octave without opening the settings dialog?

Torsten <ttl>
Project Member
Mon 11 May 2015 05:48:28 PM UTC, comment #9:

The entries in the shortcut section are:

the full file attached.

(file #33981)

Avinoam Kalma <avinoam>
Project Member
Mon 11 May 2015 05:21:54 AM UTC, comment #8:

Could you please delete the settings file again, start and exit octave and have a look into the settings file if there are any entries starting with "shortcuts"?

The default shortcuts are shown correctly. It seems that

in shortcut_manager::init are not returning the correct defaults values (def_sc) in the case when no entries are found in the settings file. I have no idea what could be the cause.

Torsten <ttl>
Project Member
Mon 11 May 2015 04:37:51 AM UTC, comment #7:

The settings of the in the shortcuts page are in the attached file.

Note that the actual values are all ctrl+, except
the new file shortcut which is ctrl+N because I have changed it manually.

(file #33973)

Avinoam Kalma <avinoam>
Project Member
Fri 08 May 2015 08:57:03 PM UTC, comment #6:

What are the settings in the shortcuts page?

John Donoghue <lostbard>
Project Member
Fri 08 May 2015 08:45:22 PM UTC, comment #5:

Deleting qt-settings did not change the situation.
Editor preferences screenshot attached.

(file #33968)

Avinoam Kalma <avinoam>
Project Member
Wed 06 May 2015 11:13:40 PM UTC, comment #4:

The file is qt-settings in

Rik <rik5>
Project Administrator
Wed 06 May 2015 09:08:02 PM UTC, comment #3:

What's the name of the preferences file and where can I find it?

Avinoam Kalma <avinoam>
Project Member
Wed 06 May 2015 07:12:17 PM UTC, comment #2:

Right. It might be a good idea to remove the preferences file for Octave entirely and have the first time Wizard re-generate it. Unless you are compiling from source after f0a8c1bc3b60, you will also need to open the Preference Settings and click the Shortcuts Tab and then hit Okay button to close the Preferences Window. This will have created a plain vanilla Octave preferences file.

Next, exit out of Octave and re-start (just to make sure new preferences are loaded) and try again.

Rik <rik5>
Project Administrator
Wed 06 May 2015 03:19:46 PM UTC, comment #1:

What settings do you have in the preferences shortcut manager?

John Donoghue <lostbard>
Project Member
Tue 05 May 2015 03:14:47 PM UTC, original submission:

I check on windows machine with Win7, and the control keys
are not working. See attached screen images.

Strangely enough, on another Win7 machine, the control keys work
well. What could be the reason for such behavior

Avinoam Kalma <avinoam>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #36743:  shortcuts.png added by avinoam (121KiB - image/png)
file #33981:  qt-settings.dat added by avinoam (39KiB - application/octet-stream)
file #33973:  shortcut_prefs.png added by avinoam (53KiB - image/png)
file #33968:  editor_prefs.png added by avinoam (68KiB - image/png)
file #33923:  ctrl1.png added by avinoam (98KiB - image/png)
file #33924:  ctrl2.png added by avinoam (103KiB - image/png)

 

Depends on the following items: None found

Digest:
   bug dependencies.

 

Carbon-Copy List
  • -email is unavailable- added by josh_g (Posted a comment)
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by jwe (Posted a comment)
  • -email is unavailable- added by ttl (Posted a comment)
  • -email is unavailable- added by lostbard (Posted a comment)
  • -email is unavailable- added by avinoam (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 13 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-09-21 rik5 Carbon-CopyRemoved 72865 => -
    2016-05-25 mtmiller Dependencies- => bugs #48011 is dependent
    2016-05-25 mtmiller Item GroupOther => Incorrect Result
        Release4.0.0 => 4.0.2
        SummaryMXE-Octave - control keys are not working in the editor => Control key shortcuts not working or configurable in Hebrew locale
    2016-03-24 avinoam Attached File- => Added shortcuts.png, #36743
    2015-06-02 jwe Release4.0.0-rc4 => 4.0.0
    2015-05-11 avinoam Attached File- => Added qt-settings.dat, #33981
    2015-05-11 avinoam Attached File- => Added shortcut_prefs.png, #33973
    2015-05-08 avinoam Attached File- => Added editor_prefs.png, #33968
    2015-05-06 rik5 StatusNone => Need Info
    2015-05-05 avinoam Attached File- => Added ctrl1.png, #33923
        Attached File- => Added ctrl2.png, #33924

    Back to the top


    Powered by Savane 3.3