bugGNU Octave - Bugs: bug #44922, Cannot change directory path of...

 
 

bug #44922: Cannot change directory path of which have Japanese Character

Submitted by:  Tatsuro MATSUOKA <tmacchant>
Submitted on:  Sat 25 Apr 2015 12:33:23 AM UTC  
 
Category:  Interpreter Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Other
Status:  Duplicate Assigned to:  None
Originator Name:  Tatsuro MATUOKA Open/Closed:  Closed
Release:  4.0.0 Operating System:  Microsoft Windows

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Tue 22 Dec 2015 04:26:39 PM UTC, comment #6: 

Closing since marked as a duplicate of bug #42036.

Mike Miller <mtmiller>
Project Administrator
Tue 02 Jun 2015 04:45:53 PM UTC, comment #5: 

Retagging release from 4.0.0-rc3 to 4.0.0.

John W. Eaton <jwe>
Project Administrator
Sun 26 Apr 2015 11:07:56 PM UTC, comment #4: 

My guess seemed not to be correct.
On usb memory (FAT 32), there was no difference of results  compared to those on the NTFS file system.

Tatsuro MATSUOKA <tmacchant>
Sat 25 Apr 2015 02:43:40 PM UTC, comment #3: 

It sounds like a good guess.  Can you get a USB memory stick and format it with one of the old file systems like FAT16 and see whether Japanese characters in the filenames on the USB stick make a difference?  That would show whether it is unicode/ASCII or something else going on.

Rik <rik5>
Project Administrator
Sat 25 Apr 2015 09:27:34 AM UTC, comment #2: 

> Is this a duplicate of bug #42036:


Sorry for the duplicated post.

> Files and directories with non-ASCII characters not handled correctly on Windows?


Yes. For ver. 3.8, only on the cli version, non-ASCII characters can be handled.

Windows now internally uses unicode for the NTFS file system but not the older FAT12, FAT16, and FAT32 file systems.
https://msdn.microsoft.com/ja-jp/library/windows/desktop/dd317748(v=vs.85).aspx

Is the above related?

Tatsuro MATSUOKA <tmacchant>
Sat 25 Apr 2015 06:05:23 AM UTC, comment #1: 

Is this a duplicate of bug #42036: Files and directories with non-ASCII characters not handled correctly on Windows?

Rik <rik5>
Project Administrator
Sat 25 Apr 2015 12:33:23 AM UTC, original submission:  

On octave 4.0.0-rc3 for MS-windows, one cannot change directory path of which have Japanese Character.

For gui, see attachment file.

For cli, I tried

>> N:\db\usr\M1\松田\解析\Prog

but the result was:

>> cd N:\db\usr\M1\
>> pwd
ans = N:\db\usr\M1

For octave 3.8, one cannot change directory path of which have Japanese Character on gui but can change on cli.

Perhaps this is not particular to the Japanese characters.
But I cannot try on Chinese or other multi-byte characters system.

Note that on Ubuntu, I can use the path name which contains Japanese characters. This is windows specific issue.

Tatsuro MATSUOKA <tmacchant>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by tiagoma
  • -email is unavailable- added by jwe (Posted a comment)
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by tmacchant (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 6 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-12-22 mtmiller Open/ClosedOpen => Closed
    2015-07-01 tiagoma Carbon-Copy- => Added tiagoma
    2015-06-02 jwe Release4.0.0-rc3 => 4.0.0
    2015-04-25 rik5 StatusNone => Duplicate
        Dependencies- => Depends on bugs #42036
    2015-04-25 tmacchant Attached File- => Added octave-gui_4.0.0rc3_win.png, #33776

    Back to the top


    Powered by Savane 3.7