bugGNU Octave - Bugs: bug #43520, Command window hangs

 
 

bug #43520: Command window hangs

Submitted by:  None
Submitted on:  Tue 04 Nov 2014 03:11:47 AM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Segfault, Bus Error, etc.
Status:  Duplicate Assigned to:  None
Originator Name:  Alexander Dunlap Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  3.8.2
Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 07 Feb 2015 04:32:04 AM UTC, comment #3: 

Closing this bug as a duplicate of bug #42681. The OP said that Ctrl-C in the command window did not cause Octave to exit. I think that can only happen if terminal output was stopped using the flow control stop character (Ctrl-S). That is now fixed, we do not allow flow control start/stop in the command window now.

If I'm wrong and this was not caused by Ctrl-S, please follow up or open a new bug report.

Mike Miller <mtmiller>
Project Administrator
Fri 06 Feb 2015 05:57:29 AM UTC, comment #2: 

Just for the record, there are two ways that I have been able to "freeze" the command window so that it doesn't respond, while the rest of the GUI seems functional.

One is with the less pager running in the command window, when running a command that takes up more than screen height. This is already open as bug #41896.

The other is when I use Ctrl-S in the command window. This sequence is normally used to pause a long-running process. The sequence Ctrl-Q unpauses the command window and lets through whatever else may have been entered while it was paused. This is already open as bug #42681.

When both of these events happen, the command window may appear to be frozen, while the rest of the GUI responds to mouse and keyboard. If the user tries to exit the GUI, nothing will happen until the command window responds, which means the pager has to exit in the first case or Ctrl-Q has to be received in the second case.

Mike Miller <mtmiller>
Project Administrator
Tue 04 Nov 2014 09:14:31 PM UTC, comment #1: 

The GUI is also experimental in 3.8.2 so if things go wrong I wouldn't be surprised, and we may have already fixed it in the code that is intended for the 4.0 release.

But, back to this bug.  Unless you can find a repeatable sequence that leads to the problem I'm not sure we can debug any further.

Rik <rik5>
Project Administrator
Tue 04 Nov 2014 03:11:47 AM UTC, original submission:  

The command window frequently hangs - other parts of the GUI continue to work but the command window is totally unresponsive. Also in these cases the GUI cannot be closed by Ctrl-C on the command line or by attempting to close the window through the window manager.

I know this probably isn't a very helpful bug report, but I'm not sure what other information would helpful since I don't know how to reproduce it. Please let me know if there is any debug information I can submit.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-02-07 mtmiller Dependencies- => Depends on bugs #42681
    2015-02-07 mtmiller StatusNeed Info => Duplicate
        Open/ClosedOpen => Closed
    2014-11-04 rik5 StatusNone => Need Info

    Back to the top


    Powered by Savane 3.5