bugGNU Octave - Bugs: bug #43250, Octave fails to build with Intel...

 
 

bug #43250: Octave fails to build with Intel Compiler

Submitted by:  Petr Belyaev <upcfrost>
Submitted on:  Thu 18 Sep 2014 04:16:35 PM UTC  
 
Category:  Configuration and Build System Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Build Failure
Status:  Invalid Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  3.8.2 Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Wed 03 Jun 2015 11:35:32 PM UTC, comment #3: 

Ok, well marking as invalid since no one has reproduced and it sounds like you are not affected by this any longer. If this problem still occurs for you please feel free to report it again.

Mike Miller <mtmiller>
Project Administrator
Wed 03 Jun 2015 10:34:09 PM UTC, comment #2: 

Hi. Sorry, i don't remember which version i was using, i've updated my pc many times after that.

I think i was using the last version available on Gentoo at 18.09.2014, which should be 4.2.1 according to changelog, but i'm not sure.

Petr Belyaev <upcfrost>
Sun 31 May 2015 12:37:28 AM UTC, comment #1: 

Sorry that no one has responded to your bug report yet, but not many developers are willing or able to use the Intel compiler.

Can you verify what version of SuiteSparse you are building against, or were when you reported this error?

There was an error in the SuiteSparse 4.3.x series that causes the build to fail with a similar error. So while it's true that we did make changes to Octave to work with newer SuiteSparse (bug #43063), but 4.3.x will still cause a build failure, you need to use either 4.2.x or 4.4.x.

Mike Miller <mtmiller>
Project Administrator
Thu 18 Sep 2014 04:16:35 PM UTC, original submission:  

Octave fails to build with Intel Compiler.
I'm using 3.8.2 release + patch from https://savannah.gnu.org/bugs/index.php?43171

It crashes like this

icpc ... -c numeric/SparseCmplxCHOL.cc -o numeric/.libs/numeric_libnumeric_la-SparseCmplxCHOL.o
In file included from /usr/include/cholmod_check.h(70),
                 from /usr/include/cholmod.h(95),
                 from ./util/oct-sparse.h(73),
                 from numeric/sparse-base-chol.h(27),
                 from numeric/SparseCmplxCHOL.h(27),
                 from numeric/SparseCmplxCHOL.cc(28):
../libgnu/stdio.h(948): error: declaration is incompatible with previous "getchar" (declared at line 538 of "/usr/include/stdio.h")
  _GL_CXXALIAS_SYS (getchar, int, (void));

And the same thing for putchar and vprintf functions.
Such error pops up for any file that uses ./liboctave/util/oct-sparse.h

The problem is somehow similar to the https://savannah.gnu.org/bugs/index.php?43171 and https://savannah.gnu.org/bugs/?43063, it occurs (imho) because of the following include chain

oct-sparse.h -> cholmod.h -> extern "C" { ... cholmod_check.h ... } -> stdio.h

As a temporal fix i've modified line 23 in stdio.in.h adding "defined CHOLMOD_H"

#if defined __need_FILE || defined __need___FILE || defined _GL_ALREADY_INCLUDING_STDIO_H || defined CHOLMOD_H

Petr Belyaev <upcfrost>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by upcfrost (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-06-03 mtmiller StatusNeed Info => Invalid
        Open/ClosedOpen => Closed
    2015-05-31 mtmiller StatusNone => Need Info

    Back to the top


    Powered by Savane 3.5