bugGNU Octave - Bugs: bug #43182, ...

 
 

bug #43182: QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed

Submitted by:  None
Submitted on:  Tue 09 Sep 2014 10:15:04 PM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Other
Status:  Invalid Assigned to:  None
Originator Name:  Hani Ibrahim Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  3.8.1
Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Sun 06 Nov 2016 03:41:22 PM UTC, comment #6: 

Actually on my Ubuntu 16.04 I get this error too, although rather randomly. It doesn't require for me to issue any specific command, nor is it reproducible with any. It just appears randomly at times.
Also the (default) value for inotify_watches is 8192 for me too.

Abhinav Tripathi <genuinelucifer>
Wed 10 Sep 2014 06:07:21 PM UTC, comment #5: 

Not sure what, if anything, Octave could do about this if/when it does occur, so closing as invalid. This is more of a system resource configuration issue. If anyone has any ideas about how to detect this or fail gracefully or silently to the user, feel free to add something.

Mike Miller <mtmiller>
Project Administrator
Wed 10 Sep 2014 05:42:15 PM UTC, comment #4: 

Thanks a lot. It works. I am amazed of your prompt and qualified response.

Thanks again, Hani

---
For novices: Just append

fs.inotify.max_user_watches=65536

in a new line to "/etc/sysctl.conf" and restart.

Hani Ibrahim <hibr01>
Wed 10 Sep 2014 05:07:13 PM UTC, comment #3: 

Thanks. Try bumping that number up with

sudo sysctl fs.inotify.max_user_watches=65536

and see whether that eliminates the error for you. I'm surprised that 65536 is not the default, since it looks to me to be the default on Ubuntu 14.04, which is the basis for Mint 17.

This change will only take effect until the next reboot, if you want to make it permanent you'll have to add it to /etc/sysctl.conf.

Mike Miller <mtmiller>
Project Administrator
Wed 10 Sep 2014 04:54:16 PM UTC, comment #2: 

Here is the result on my system:

~ $ sysctl fs.inotify.max_user_watches
fs.inotify.max_user_watches = 8192

Hani

Hani Ibrahim <hibr01>
Wed 10 Sep 2014 02:25:06 AM UTC, comment #1: 

Thanks for your bug report. Some quick searching shows that this error message is not really due to a full partition, but is due to using up all of the inotify watches allowed per user. What value does the following show on your Mint system?

sysctl fs.inotify.max_user_watches

Mike Miller <mtmiller>
Project Administrator
Tue 09 Sep 2014 10:15:04 PM UTC, original submission:  

Start "octave --force-gui" on Linux Mint 17 64-bit, in the command window the following message appears before normal octave prompt:

QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No space left on device
Warning: QFileSystemWatcher: failed to add paths: /home/hi
GNU Octave, version 3.8.1

This appears after each filesystem command (as cd). There is enough space on the drive:

$ df -h
Filesystem                       Size  Used Avail Use% Mounted on
/dev/mapper/mint--vg-root        455G  205G  228G  48% /
none                             4.0K     0  4.0K   0% /sys/fs/cgroup
udev                             1.9G  4.0K  1.9G   1% /dev
tmpfs                            376M  1.4M  374M   1% /run
none                             5.0M     0  5.0M   0% /run/lock
none                             1.9G  744K  1.9G   1% /run/shm
none                             100M   16K  100M   1% /run/user
/dev/sda1                        236M   46M  178M  21% /boot
192.168.2.251:/volume1/homes/hi  2.7T  492G  2.3T  18% /home/hi/DS-Home

There is just one partition and the whole drive is encrypted.

Hani

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by genuinelucifer (Posted a comment)
  • -email is unavailable- added by hibr01 (Posted a comment)
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2014-09-10 mtmiller StatusNeed Info => Invalid
        Open/ClosedOpen => Closed
    2014-09-10 mtmiller StatusNone => Need Info

    Back to the top


    Powered by Savane 3.5