bugGNU Octave - Bugs: bug #43067, wrong legend position (either...

 
 

bug #43067: wrong legend position (either after multiline title or in subplots)

Submitted by:  Hartmut <hardy>
Submitted on:  Mon 25 Aug 2014 04:23:11 PM UTC  
 
Category:  Plotting with OpenGL Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Inaccurate Result
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  3.8.2 Operating System:  Any

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 25 Apr 2015 05:38:13 AM UTC, comment #1: 

This is a duplicate of bug #39697.  Keeping original and closing this one.

Rik <rik5>
Project Administrator
Mon 25 Aug 2014 04:23:11 PM UTC, original submission:  

Here is a short sample that shows the behavior:

graphics_toolkit('fltk');
close all;

figure(1);
plot(1:10);
legend('legend A');
title({'line 1','line 2'});

figure(2);
subplot(2,1,1);
plot(1:10);
legend('legend B'); % will be misplaced
title({'line 1','line 2'});


subplot(2,1,2);
plot(1:10);
legend('legend C');
title({'line 1','line 2'});

With the fltk plotting frontend the "Legend B" will be displaced by a lot, compared to the other two legends. I would say it's placed wrong. This happens on Linux as well as on Windows (MXE).

Addidtionally "legend A" also seems to be a bit off the right position.

With gnuplot as well as with Matlab all three legends are positioned in a similar manner inside the box, and look fine to me.

If you make the title a one line object, then it looks much better. Then, only legend B (in the subplot) is off position.

Also the order of calling "title" and "legend" seems to be important. If you swap those function calls, the result looks totally fine.

Hartmut <hardy>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by hardy (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-04-25 rik5 StatusNone => Duplicate
        Open/ClosedOpen => Closed
        Dependencies- => Depends on bugs #39697

    Back to the top


    Powered by Savane 3.5