bugGNU Octave - Bugs: bug #42940, Changing all fontsizes in plot...

 
 

bug #42940: Changing all fontsizes in plot gives warning when legend present

Submitted by:  Rik <rik5>
Submitted on:  Fri 08 Aug 2014 03:42:06 AM UTC  
 
Category:  Plotting Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  Open
Release:  dev Operating System:  Any

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 17 Nov 2016 10:40:20 AM UTC, comment #1:

This bug is still present in the current dev 4.3.0 (39f39eb4e476).

I filed task #14243 about rewriting legend.m

Pantxo Diribarne <pantxo>
Project Member
Fri 08 Aug 2014 03:42:06 AM UTC, original submission:

The problem is that the legend object has text objects underneath it as well as having a fontsize property. When the fontsize is changed on the underlying text objects the legend axes object is destroyed and re-created. See bug #41142. This causes an error when the set() function tries to address the non-existent legend object.

Sample code:

Rik <rik5>
Project Administrator

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Digest:
   bug dependencies.

 

Carbon-Copy List
  • -email is unavailable- added by pantxo (Posted a comment)
  • -email is unavailable- added by rik5
  • -email is unavailable- added by rik5 (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2014-08-08 rik5 StatusConfirmed => Duplicate
    2014-08-08 rik5 Carbon-Copy- => Added -email is unavailable-
    2014-08-08 rik5 StatusNone => Confirmed
    2014-08-08 rik5 Dependencies- => bugs #42884 is dependent
    2014-08-08 rik5 Dependencies- => Depends on bugs #41142

    Back to the top


    Powered by Savane 3.3