bugGNU Octave - Bugs: bug #41467, Workspace dock need not update...

 
 

bug #41467: Workspace dock need not update while Octave is busy running code

Submitted by:  Felipe G. Nievinski <fgnievinski>
Submitted on:  Wed 05 Feb 2014 08:56:30 PM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Performance
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  dev Operating System:  Any

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 06 Feb 2014 01:42:03 PM UTC, comment #2: 

indeed, pls close this one as a duplicate of bug #39646

Felipe G. Nievinski <fgnievinski>
Thu 06 Feb 2014 03:50:00 AM UTC, comment #1: 

I think this was a desired feature, to be able to see intermediate results while long scripts or functions are executing. I don't have a reference to back that up at the moment though, may be in the mailing list archives.

See also bug #39646, one of these could be considered a duplicate of the other.

Mike Miller <mtmiller>
Project Administrator
Wed 05 Feb 2014 08:56:30 PM UTC, original submission:  

currently it gets updated recursively for every function that gets called internally by the function actually called by the user.  that's a lot of overhead, for something that changes so rapidly you only see the workspace dock flashing.  it could wait, until either execution is finished or interrupted by a debug command.

Felipe G. Nievinski <fgnievinski>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by fgnievinski (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2014-02-06 mtmiller StatusNeed Info => Duplicate
        Open/ClosedOpen => Closed
        Dependencies- => Depends on bugs #39646
    2014-02-06 mtmiller StatusNone => Need Info

    Back to the top


    Powered by Savane 3.5