bugGNU Octave - Bugs: bug #41055, GUI doc browser does not support...

 
 

bug #41055: GUI doc browser does not support compressed info

Submitter:  Mike Miller <mtmiller>
Submitted:  Wed 01 Jan 2014 03:57:32 PM UTC
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  * Closed
Release:  * dev Operating System:  * GNU/Linux
Fixed Release:  None Planned Release:  None
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Wed 01 Jan 2014 08:35:15 PM UTC, comment #3: 

Changeset
http://hg.savannah.gnu.org/hgweb/octave/rev/d03a6d272fee
provides an error message when the info file is missing.

Closing bug report since the remaining issue is a duplicate of bug #38305.

Torsten Lilge <ttl>
Project Member
Wed 01 Jan 2014 07:04:39 PM UTC, comment #2: 

The document browser supports compressed info files but due to bug #38305, the process handling for unzipping the files does not work.

I will prepare a patch for the case where the info files are missing.

Torsten Lilge <ttl>
Project Member
Wed 01 Jan 2014 04:58:06 PM UTC, comment #1: 

More detail: the index page is visible, scrollable, and searchable, but clicking any links or doing a global keyword search causes the entire GUI to freeze and has to be killed.

On a related note, if the info files are not present (e.g. if the Debian octave-info packages is not installed), the doc browser shows up empty without any indication of why there is no documentation.

Mike Miller <mtmiller>
Project Administrator
Wed 01 Jan 2014 03:57:32 PM UTC, original submission:  

Linux distributions frequently gzip-compress info files to save space, which does not currently work with the GUI built-in documentation browser.

Mike Miller <mtmiller>
Project Administrator

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Digest:
   bug dependencies.

 

Carbon-Copy List
  • -email is unavailable- added by ttl (Posted a comment)
  • -email is unavailable- added by mtmiller (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2014-09-18 ttl Dependencies- bugs #43247 is dependent
    2014-01-03 mtmiller Dependencies- bugs #41075 is dependent
    2014-01-01 ttl StatusNone Duplicate
        Open/ClosedOpen Closed

    Back to the top

    Powered by Savane 3.9