bugGNU GRUB - Bugs: bug #40552, GRUB misconfigures BIOS...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #40552: GRUB misconfigures BIOS framebuffer as EFI

Submitted by:  Eli <eliptus>
Submitted on:  Tue 12 Nov 2013 01:52:08 AM UTC  
 
Category: BootingSeverity: Major
Priority: 5 - NormalItem Group: Software Error
Status: Wont FixPrivacy: Public
Assigned to: NoneOriginator Name: 
Open/Closed: ClosedRelease: 
Release: otherReproducibility: None
Planned Release: None

Tue 12 Nov 2013 07:19:58 PM UTC, comment #4:

I appreciate the quick response despite the bug being closed as "Won't Fix".

I don't see an actual bug referenced in the article that you linked. Perhaps I misunderstand how such requests are tracked by kernel.org?

My setup is a simple KVM (at buyvm.net). I'll attach the output of "hwinfo --framebuffer", but let me know if there are other details you prefer.

(file #29598)

Eli <eliptus>
Tue 12 Nov 2013 05:40:31 PM UTC, comment #3:

http://lwn.net/Articles/401883/

I don't know what your system is, you'd need to supply more details for this. On some systems GRUB chooses its native drivers if available rather than relying on BIOS.

Vladimir Serbinenko <phcoder>
Project Administrator
Tue 12 Nov 2013 05:32:53 PM UTC, comment #2:

Bug ID or it didn't happen... Can you please provide the bug that was filed against the kernel for a generic linear framebuffer ID?

My case is clearly not the one that you describe and the GRUB manual claims "grub-mkconfig will normally load all available GRUB video drivers and use the one most appropriate for your hardware". Provided such claim, it is reasonable to expect that "vesafb" be used in a fairly standard case line mine.

Also, wouldn't an alternative to forcing the EFI driver be loaded in the case that you describe be to allow the kernel to perform it's own auto-detection, similar to how I did bye setting "GRUB_VIDEO_BACKEND=true"?

All that said, this, at the very least, warrants documentation in the GRUB manual. From the many forums I've read, this appears to be a plague upon the Linux community. People are more inclined to forgo graphics support in GRUB, in favor of graphics support in the kernel, without going to the extent of determining that GRUB wants EFI support in their kernel built for a BIOS system.

Eli <eliptus>
Tue 12 Nov 2013 12:00:04 PM UTC, comment #1:

I've been asking Linux guys to provide a generic linear framebuffer id for ages for the cases when GRUB uses own driver and hence "vesafb" isn't right type (as there may be no VBE available at all). Until such id is provided there is nothing GRUB can do better than using efi one since it does essentially that.

Vladimir Serbinenko <phcoder>
Project Administrator
Tue 12 Nov 2013 01:52:08 AM UTC, original submission:

I'm currently using grub-2.00_p5107-r2 on Gentoo. Using GRUB's default configuration, but setting "GRUB_GFXPAYLOAD_LINUX=1024x768" in /etc/default/grub would result in a blank screen unless I enabled "efifb" in the kernel. This is unexpected since I'm running a BIOS system and the framebuffer is expected to use "vesafb".

As a test, I set "GRUB_VIDEO_BACKEND=true" in /etc/default/grub, disabling GRUB's loading of it's video modules. Doing so resulted in the kernel correctly matching the framebuffer to the "vesafb" driver. Further experimentation showed that setting "GRUB_VIDEO_BACKEND=vbe" also resulted in the correct behavior.

Using "all_video" or any other video module incorrectly resulted in matching of "efifb".

Eli <eliptus>

 

Attached Files
file #29598:  hwinfo-framebuffer.txt added by eliptus (3KiB - text/plain)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by phcoder (Posted a comment)
  • -unavailable- added by eliptus (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Tue 12 Nov 2013 07:19:58 PM UTCeliptusAttached File-=>Added hwinfo-framebuffer.txt, #29598
    Tue 12 Nov 2013 12:00:04 PM UTCphcoderStatusNone=>Wont Fix
      Open/ClosedOpen=>Closed

    Back to the top


    Powered by Savane 3.1-cleanup1