buglibiconv - Bugs: bug #35088, Patch for native Visual Studio...

 
 

bug #35088: Patch for native Visual Studio 2010 compilation

Submitted by:  Thomas Lemm <thomaslemm>
Submitted on:  Fri 16 Dec 2011 03:07:03 PM UTC  
Votes:  10  
 
Category:  Build Severity:  3 - Normal
Item Group:  None Status:  Not a Bug
Privacy:  Public Assigned to:  Bruno Haible <haible>
Open/Closed:  Closed

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Wed 23 Nov 2016 11:26:21 PM UTC, comment #2:

I have now updated (in git) the README.windows with instructions how to build libiconv with MSVC. The added complexity is minimal, this way.

Bruno Haible <haible>
Project AdministratorIn charge of this item.
Sat 19 Nov 2016 02:39:54 PM UTC, comment #1:

Thanks.

But the cost vs. benefit evaluation of adopting your patch is negative.

The benefits of your patch:
- Instead of having one way to build native Windows binaries, there are two ways. This is little benefit.
- Instead of using gcc, it uses the Microsoft compiler. This may indeed be useful in some cases, but the more maintainable way to achieve this is by combining the MSVC support in gnulib with a command-line build that uses configure.

The drawback of your patch is maintenance cost: It requires updates
- each time something in the build infrastructure, e.g. config.h.in, changes,
- each time iconv.h.in or libcharset.h.in or localcharset.h.in changes,
- when moving to newer versions of the Microsoft development tools.
For example, the list of include files (one per encoding) is replicated in VC10/iconv.vcxproj and VC10/iconv.vcxproj.filters.

The GNU build system is based on automatic generation of artefacts, based on a few sources (mostly configure.ac, Makefile.am). This is the path that should be followed for new additions.

Bruno Haible <haible>
Project AdministratorIn charge of this item.
Fri 16 Dec 2011 03:07:03 PM UTC, original submission:

Hi,
please find attached a patch (based on libiconv 1.14) to support
native Visual Studio 2010 compilation. An explanation is added to the (patched) readme.woe32 file.

Most changes are in an added windows/VC10 directory. Only minor
changes are made to the other source files which should not break anything (I hope).

Hope this makes it into a release

Kind regards

Thomas Lemm

(Thomas.Lemm@gmx.de)

Thomas Lemm <thomaslemm>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #24607:  libiconv-1.14.vc10.patch added by thomaslemm (117KiB - application/octet-stream)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by haible (Posted a comment)
  • -email is unavailable- added by partyd (Voted in favor of this item)
  • -email is unavailable- added by thomaslemm (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 10 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 6 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    Wed 23 Nov 2016 11:57:44 PM UTC haible CategoryNone => Build
    Sat 19 Nov 2016 02:39:54 PM UTC haible Open/ClosedOpen => Closed
    Sat 19 Nov 2016 02:39:53 PM UTC haible StatusNone => Not a Bug
        Assigned toNone => haible
    Wed 03 Aug 2016 05:56:12 PM UTC partyd Carbon-Copy- => Added partyd
    Fri 16 Dec 2011 03:07:03 PM UTC thomaslemm Attached File- => Added libiconv-1.14.vc10.patch, #24607

    Back to the top


    Powered by Savane 3.3