bugmake - Bugs: bug #34310, pattern rule chains give...

 
 

bug #34310: pattern rule chains give misleading error message

Submitted by:  None
Submitted on:  Sat 17 Sep 2011 01:33:01 AM UTC  
 
Severity:  3 - Normal Item Group:  Bug
Status:  Not A Bug Privacy:  Public
Assigned to:  None Open/Closed:  Closed
Component Version:  3.82 Operating System:  None
Fixed Release:  None Triage Status:  None

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 17 Sep 2011 01:46:56 AM UTC, comment #1: 

Make cannot give such an error.  You think it can because you already know what the answer should have been so it seems obvious to you, but make doesn't know that answer.  Make may try hundreds of different suffix and pattern rules looking for a rule that can build a given target: there's no way, since no rule matches, to know what rule it "should" have found and hence no way to choose what message to print.

If you want to see all the different ways make tried to find a rule to build a given target, that's already available via the debug output.

Paul D. Smith <psmith>
Project Administrator
Sat 17 Sep 2011 01:33:01 AM UTC, original submission:  

I suspect this is a known issue but if you have a chain of pattern rules, and a missing file at the bottom end of the chain, make doesn't tell you whats going on but instead reports that there is 'no rule to make foo.built'.  Using static pattern rules instead of general pattern rules hides the problem but it seems that make should be able to give a clue about what is going on without this, or at least not say that the rule doesn't exist when in fact its a dependency further down the chain that is missing.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by psmith (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2011-09-17 psmith StatusNone => Not A Bug
        Open/ClosedOpen => Closed

    Back to the top


    Powered by Savane 3.6