bugGNU nano - Bugs: bug #24028, UTF-8 problems on solaris

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #24028: UTF-8 problems on solaris

Submitted by:  Andras Barna <sartek>
Submitted on:  Sat 09 Aug 2008 08:23:25 PM UTC  
 
Severity:  3 - Normal Status:  Works For Me
Assigned to:  Chris Allegretta <astyanax> Open/Closed:  Closed

( Jump to the original submission)

Fri 13 Jun 2014 04:19:08 PM UTC, comment #6: 

Bug is too old.  Please open a new one when you still have issues with UTF-8 and nano anywhere.

Benno Schulenberg <bens>
Project Administrator
Sun 14 Dec 2008 09:12:15 AM UTC, comment #5: 

Andras, that solution doesn't work for me on opensolaris 2008.11... ncursesw/curses.h does not exist even with SUNWncurses package installed.

Anonymous
Sun 24 Aug 2008 03:12:24 PM UTC, comment #4: 

it's opensolaris (update 95)
ncurses(w) will be integrated to opensolaris (see http://opensolaris.org/os/community/arc/caselog/2008/524)

currently i have installed from source using pkgbuild & sfe (http://pkgbuild.sourceforge.net/spec-files-extra/)
but there's a spec file now on src.opensolaris.org too (http://src.opensolaris.org/source/xref/jds/spec-files/trunk/SUNWncurses.spec)

unfortunately no packages yet. so you can build it or download my packages from: http://sartekDOTnet/~sartek/SFE/

thanks

Andras Barna <sartek>
Sun 24 Aug 2008 03:05:23 AM UTC, comment #3: 

Nano's curses detection has always been very automatic and not very overridable.  This is something that's needed fixing for some time.  Anyway, regardless, I didnt see ncursesw either in the sunfreeware curses package, nor did I see it in the Solaris package manager. 

Can you give more details about what OS version and ncurses package is installed on this system, for me to try and replicate it?

Chris Allegretta <astyanax>
Project AdministratorIn charge of this item.
Tue 12 Aug 2008 06:04:26 PM UTC, comment #2: 

if you wish i can test, just give a patch or something

thanks!

btw: what's the problem?

Andras Barna <sartek>
Tue 12 Aug 2008 05:56:47 PM UTC, comment #1: 

trying to replicate and test but am unable to get OpenSolaris to even install, argh.

Chris Allegretta <astyanax>
Project AdministratorIn charge of this item.
Sat 09 Aug 2008 08:23:25 PM UTC, original submission:  

the problem:

on solaris there's a "builtin" curses library (non-ncurses)
if there's also ncursesw, nano.h picks up curses.h from solaris'
which results in compilation failure.

a solution should be:
if on the system is ncursesw and we need utf-8
include "<ncursesw/curses.h>" not "<curses.h>"

Andras Barna <sartek>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by bens (Posted a comment)
  • -email is unavailable- added by astyanax (Posted a comment)
  • -email is unavailable- added by sartek (Submitted the item)
  • -email is unavailable- added by sartek
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2014-06-13 bens StatusNeed Info => Works For Me
        Open/ClosedOpen => Closed
    2008-08-24 astyanax StatusNone => Need Info
    2008-08-12 astyanax Assigned toNone => astyanax
    2008-08-09 sartek Carbon-Copy- => Added sartek

    Back to the top


    Powered by Savane 3.5