bugw3 - Bugs: bug #21601, Wrong handling of relative links...

 
 

bug #21601: Wrong handling of relative links with only query part

Submitted by:  Magnus Henoch <legoscia>
Submitted on:  Sat 17 Nov 2007 01:33:03 PM UTC  
 
Category:  None Severity:  3 - Normal
Item Group:  None Status:  None
Privacy:  Public Assigned to:  None
Open/Closed:  Open

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun 18 Nov 2007 12:04:56 PM UTC, comment #1:

It seems that the bug resides in url-default-expander in Emacs' URL library:

      • Welcome to IELM *** Type (describe-mode) for help.

ELISP> (defun test-url-expand ()
(let ((relative (url-generic-parse-url "?foo"))
(base (url-generic-parse-url "http://foo/bar/baz.html")))
(url-default-expander relative base)
relative))
test-url-expand
ELISP> (test-url-expand)
[cl-struct-url "http" nil nil "foo" 80 "/bar?foo" nil nil nil]

Magnus Henoch <legoscia>
Project Administrator
Sat 17 Nov 2007 01:33:03 PM UTC, original submission:

If the page http://foo/bar/baz.html contains a link ?foo, the link should point to http://foo/bar/baz.html?foo, but W3 currently makes it http://foo/bar?foo.

Magnus Henoch <legoscia>
Project Administrator

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by legoscia (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    No changes have been made to this item

    Back to the top


    Powered by Savane 3.3