taskGNU Health - Tasks: task #13726, Add support for Red Hat

 
 

You are not allowed to post comments on this tracker with your current authentication level.

task #13726: Add support for Red Hat

Submitted by:  Bruno M. Villasanti <bvillasanti>
Submitted on:  Tue 25 Aug 2015 10:26:20 PM UTC
 
Should Start On:  Tue 25 Aug 2015 03:00:00 AM UTC Should be Finished on:  Fri 20 Nov 2015 03:00:00 AM UTC
Category:  Operating System Priority:  * 5 - Normal
Status:  Ready For Test Privacy:  Public
Percent Complete:  100% Assigned to:  bvillasanti
Open/Closed:  Open Release:  * 2.9.0
Module:  * Installer
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       No canned response available

 

Fri 20 Nov 2015 11:32:53 PM UTC, comment #3: 

Installation instructions added to the section Operating System specific notes.

Steps include both the particularities of Red Hat, such as CentOS.

Regards.

Bruno M. Villasanti <bvillasanti>
Wed 18 Nov 2015 02:38:24 PM UTC, comment #2: 

Hi Luis,

I retry the installation, and dismiss this error.

The compilation of `psycopg2` runs smoothly using libraries based Red Hat / CentOS (PostgreSQL 9.2) repository.

I'm finishing installation tests in CentOS / Fedora / RedHat.

I will be updating the wiki soon.

Regards,
Bruno

Bruno M. Villasanti <bvillasanti>
Mon 31 Aug 2015 08:25:21 PM UTC, comment #1: 

Thanks, Bruno !

Does it happen also in CentOS ?  If so, we can create a section on the installer for both.

Anyways, I think it's probably best to concentrate on updating the installation script for the upcoming release of GNU Health 3.0 (Nov 24th).

Let me know your thoughts

Luis

Luis Falcon <meanmicio>
Project Administrator
Tue 25 Aug 2015 10:26:20 PM UTC, original submission:  

After testing the installation over Red Hat [1], (having adapted the prerequisites described in the Wiki) an error occurs processing the psycopg2 package of installation script that makes necessary to modify the method.

  • Alternative method:

"Move the psycopg2 package installation from script (made by pip) to the section installation requirements for the Red Hat operating system".

  • Steps:

1. Remove psycopg2 installation via pip from script installer; only for Red Hat (by prior detection of the Operating System).
2. Include the python-psycopg2 package dependencies installation for Red Hat Operating System in the respective Section of the Wiki.

Awaiting validation feedback or some alternative method proposed.

Regards.

--
[1] Environment detail:

    Red Hat Enterprise Linux Server release 7.1 (Maipo)
    PostgreSQL 9.4
    Python 2.7
    pip 7.1
    Tryton 3.4
    GNU Health 2.8

[2] Traceback:

    [15:21:26] >> psycopg2==2.5.4
    Collecting psycopg2==2.5.4
    /usr/lib/python2.7/site-packages/pip-7.1.0-py2.7.egg/pip/_vendor/requests/packages/urllib3/util/ssl_.py:90: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
      InsecurePlatformWarning
      Downloading psycopg2-2.5.4.tar.gz (682kB)
        100% |████████████████████████████████| 684kB 19kB/s
        Complete output from command python setup.py egg_info:
        running egg_info
        creating pip-egg-info/psycopg2.egg-info
        writing pip-egg-info/psycopg2.egg-info/PKG-INFO
        writing top-level names to pip-egg-info/psycopg2.egg-info/top_level.txt
        writing dependency_links to pip-egg-info/psycopg2.egg-info/dependency_links.txt
        writing manifest file 'pip-egg-info/psycopg2.egg-info/SOURCES.txt'
        warning: manifest_maker: standard file '-c' not found

       

        Error: pg_config executable not found.

       

        Please add the directory containing pg_config to the PATH
        or specify the full executable path with the option:

       

            python setup.py build_ext --pg-config /path/to/pg_config build ...

       

        or with the pg_config option in 'setup.cfg'.

       

        ----------------------------------------
    Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-EP5W69/psycopg2

Bruno M. Villasanti <bvillasanti>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by meanmicio (Posted a comment)
  • -email is unavailable- added by bvillasanti (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

     

     

     

    Follow 6 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-11-20 bvillasanti StatusIn Progress => Ready For Test
        Percent Complete50% => 100%
    2015-11-18 bvillasanti Should be Finished on2015-08-25 => 2015-11-20
        StatusNeed Info => In Progress
        Percent Complete10% => 50%
    2015-08-31 meanmicio ReleaseNone => 2.9.0

    Back to the top


    Powered by Savane 3.9