taskSavannah Administration - Tasks: task #13173, Chromium vs. Savannah mens

 
 

task #13173: Chromium vs. Savannah mens

Submitted by:  jidanni
Submitted on:  Sat 29 Mar 2014 03:07:52 AM UTC  
 
Should Start On: Sat 29 Mar 2014 12:00:00 AM UTCShould be Finished on: Sat 29 Mar 2014 12:00:00 AM UTC
Category: Approved Projects to be ReviewedPriority: 5 - Normal
Status: NonePrivacy: Public
Percent Complete: 0%Assigned to: None
Open/Closed: OpenEffort: 0.00

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Tue 01 Apr 2014 03:24:22 AM UTC, comment #7:

OK I submitted https://code.google.com/p/chromium/issues/detail?id=358499

jidanni
Mon 31 Mar 2014 04:51:36 AM UTC, comment #6:

OK I can reproduce it on my jidanni2 machine but not my jidanni3 machine. I still have to test my jidanni3 and jidanni6 machines...

jidanni
Mon 31 Mar 2014 02:07:27 AM UTC, comment #5:

I cannot recreate the problem. I tried your test case but I still could not reproduce a problem with the pulldown menus. I am using chromium 33.0.1750.152 Debian jessie/sid (256984) at this time.

Because you were able to show that it is affected by locale I think this must be a bug in chromium. And in particular your particular chromium since the test recipe did not create a problem for me when I tried it with zh_TW.UTF-8 locale. (shrug)

I just looked at the feature. It is CSS. The way it works is that the submenus are visibility:hidden. Then when the Tasks item is hovered upon (li.topmenuitemmainitem:hover) then it sets the visibility to visible. This is what makes the menus show and hide.

Bob Proulx <rwp>
Site Administrator
Sat 29 Mar 2014 04:10:58 AM UTC, comment #4:

Here's the exact steps I used to reproduce this issue!
# set http://savannah.gnu.org/task/?13173
# su - nobody -c 'LC_CTYPE=zh_TW.UTF-8 HOME=/tmp/$$ chromium '$@&
Then put the mouse upon e.g., Tasks in the
"Main Homepage Support Mailing Lists Source Code Tasks News"
line above, and attempt to even click on the "Browse" item contained!
The drop down menu disappears before you even get a chance!

jidanni
Sat 29 Mar 2014 04:00:06 AM UTC, comment #3:

$ LC_CTYPE=zh_TW.UTF-8 chromium #has the bug
$ LC_CTYPE=en_US.utf8 chromium #doesn't !

jidanni
Sat 29 Mar 2014 03:53:58 AM UTC, comment #2:

s/mens/menus/ in title above.

jidanni
Sat 29 Mar 2014 03:34:08 AM UTC, comment #1:

All I know is I had to do
$ su - nobody
to get it working on a clean account.
Not even doing chromium --temp-profile worked on my current account here on debian with chromium Version 33.0.1750.152 Debian jessie/sid (256984)

jidanni
Sat 29 Mar 2014 03:07:52 AM UTC, original submission:

Please test that the menus still work in chromium.
E.g. one sees above "Main Homepage Support ..."
Well in Chromium Version 33.0.1750.152 Debian jessie/sid (256984)
the moment one moves the mouse down to look into their drop-down menus, that menu disappears! One must use a different browser to report anything.

jidanni

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by rwp (Posted a comment)
  • -unavailable- added by jidanni (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follows 1 latest change.

    Date Changed By Updated Field Previous Value => Replaced By
    Mon 31 Mar 2014 02:07:27 AM UTCrwpCategoryNone=>Approved Projects to be Reviewed

    Back to the top


    Powered by Savane 3.1-cleanup