helpGNU gettext - Support: sr #108118, Build fails with recent glibc due...


sr #108118: Build fails with recent glibc due to outdated gnulib

Submitted by:  Brandon Invergo <brandon>
Submitted on:  Wed 22 Aug 2012 05:35:04 PM UTC  
Category: NonePriority: 5 - Normal
Severity: 3 - NormalStatus: None
Privacy: PublicAssigned to: None
Open/Closed: OpenOperating System: None

Add a New Comment (Rich MarkupRich Markup):

You are not logged in

Please log in, so followups can be emailed to you.


Wed 22 Aug 2012 05:39:05 PM UTC, comment #1:

Upstream patch:

Brandon Invergo <brandon>
Wed 22 Aug 2012 05:35:04 PM UTC, original submission:

Building gettext fails with recent versions of glibc (2.16+). The error occurs in files pulled in from gnulib, for example:

In file included from closeout.c:22:0:
./stdio.h:456:1: error: 'gets' undeclared here (not in a function)
make[6]: *** [closeout.o] Error 1
make[6]: Leaving directory `/home/brandon/Projects/gsrc/gsrc/trunk/gnu/gettext/work/gettext-'

The error exists in three files:

The problem has already been fixed upstream in gnulib, so it should be as simple as updating the code included in gettext.

Brandon Invergo <brandon>


(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):

No files currently attached


Depends on the following items: None found

Items that depend on this one: None found


Carbon-Copy List
  • -unavailable- added by brandon (Submitted the item)

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.


    Please enter the title of George Orwell's famous dystopian book (it's a date):



    No Changes Have Been Made to This Item

    Back to the top

    Powered by Savane 3.1-cleanup