helpGNU Libtool - Support: sr #102347, AIX whole_archive_... revisited

 
 

sr #102347: AIX whole_archive_... revisited

Submitted by:  AT <thomason>
Submitted on:  Mon 11 Aug 2003 10:58:57 PM UTC  
 
Category: NonePriority: 5 - Normal
Severity: 2 - MinorStatus: None
Privacy: PublicAssigned to: None
Open/Closed: OpenOperating System: None

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 11 Aug 2003 10:58:57 PM UTC, original submission:

Since CVS revision 1.294 my convenience library on AIX
has broken. This seems to be because that patch
removes $convenience from $deplibs, but AIX (at least
with my configuration) has $whole_archive_flag_spec='
'. This problem was anticipated by chrisp in reply to
support #100049 on Sun 09/09/2001. There was a
discussion on the libtool list in May '01 regarding the
empty $whole_archive_flag_spec, but apparently there
was never a resolution (libtool.m4 in today's cvs still
contains _LT_AC_TAGVAR(whole_archive_flag_spec, $1)=' '
at line 2859).

Is this a bug introduced by the 1.294 patch or is there
a way around it for AIX?

-Adam Thomason

P.S. This aside, libtool has made my life much easier;
thanks to all the developers for their efforts.

AT <thomason>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

CC list is empty

 

Do you think this task is very important?
If so, you can click here to add your encouragement to it.
This task has 0 encouragements so far.

Only logged-in users can vote.

 

Please enter the title of George Orwell's famous dystopian book (it's a date):

 

 

No Changes Have Been Made to This Item

Back to the top


Powered by Savane 3.1-cleanup