helpGDB - Support: sr #109874, GDB blocks Guile 2.2 modules from...

 
 

sr #109874: GDB blocks Guile 2.2 modules from building

Submitted by:  None
Submitted on:  Sun 11 Aug 2019 02:37:27 PM UTC  
 
Category:  None Priority:  5 - Normal
Severity:  3 - Normal Status:  None
Privacy:  Public Assigned to:  None
Originator Email:  -email is unavailable- Open/Closed:  Open
Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun 11 Aug 2019 02:37:27 PM UTC, original submission:  

On Antergos GNU/Linux using the Arch repos, when attempting to build modules that use Guile 2.2 - such as `guile-qnome` - while GDB is currently installed causes this error:
`configure: error: found development files for Guile 2.2, but /usr/bin/guile2.0 has effective version 2.0`.

To work around this I have to remove Guile 2.0 every single time I want to build modules that use version 2.2. This also means removing GDB, as it is a dependency. Once finished building and installing, Guile 2.0 and GDB will reinstall without issue.

The fixes I can think of are either: for GDB to port to Guile 2.2 or for Guile to allow multiple versions of the development files at the same time. The latter option would be better as languages Python can work just fine with multiple versions installed.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    No changes have been made to this item

    Back to the top


    Powered by Savane 3.5