patchGNU Octave - Patches: patch #8099, io-1.3.6 (for Octave development...

 
 

patch #8099: io-1.3.6 (for Octave development version 3.7.2+ ONLY)

Submitted by:  Philip Nienhuis <philipnienhuis>
Submitted on:  Fri 28 Jun 2013 02:24:51 PM UTC  
 
Category: NonePriority: 5 - Normal
Status: DonePrivacy: Public
Assigned to: Philip Nienhuis <philipnienhuis>Open/Closed: Closed

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Wed 01 Jan 2014 11:07:04 PM UTC, comment #16:

I just uploaded io-2.0.0 to the package release forum.

I found no more texinfo issues; browsing the generated html looks fine.

Philip Nienhuis <philipnienhuis>
Project MemberIn charge of this item.
Wed 01 Jan 2014 12:02:48 PM UTC, comment #15:

On a Win7 box w. Octave 3.9.0+ (a little older dev version) it installed OK, but with a similar message.

Although I wonder what the essential difference between our boxes is w.r.t. this error, it doesn't matter much anymore as I've fixed the texinfo stuff (& other bugs).

The "@bye seen before @end deftypefn" may be from get_help_text() (?).
"(A(1) index out of bounds" is definitely a bug in get_first_help_sentence. I posted a bug report (bug #41053).

Philip Nienhuis <philipnienhuis>
Project MemberIn charge of this item.
Wed 01 Jan 2014 12:10:13 AM UTC, comment #14:

"pkg install -nodeps -verbose io-1.3.6.tar.gz" directly from octave fails as well, with a small difference at the end of the message:

/tmp/octave-help-FdesIT:97: @bye seen before @end deftypefn
A(I): index out of bounds; value 1 out of bound 0
error: called from 'get_first_help_sentence>first_sentence_texinfo' in file /usr/share/octave/3.8.0/m/help/get_first_help_sentence.m near line 127, column 13
error: called from:
error: /usr/share/octave/3.8.0/m/pkg/private/install.m at line 241, column 5
error: /usr/share/octave/3.8.0/m/pkg/pkg.m at line 394, column 9

Anonymous
Tue 31 Dec 2013 08:19:49 PM UTC, comment #13:

test_spsh.m is a test function that automatically finds all supported spreadsheet interfaces and tests them one by one, invoking the two other functions io_xls_testscript.m and io_ods_testscript.m

I once figured they'd better be put in a demo/ subdir.
OTOH they do serve some useful purpose for users: running test_spsh.m clearly shows whether the spreadsheet I/O functions work properly.

In the mean time I've prepared a little more informative texinfo header.
With a little luck it'll be in io-2.0.0 later tonight, or tomorrow, in the package release tracker.

BTW:
I'm a bit suspicious about get_first_help_sentence.m, it shouldn't bomb out like in comment #9, not even in case of bad texinfo.

Philip Nienhuis <philipnienhuis>
Project MemberIn charge of this item.
Tue 31 Dec 2013 05:23:37 PM UTC, comment #12:

What's the `test_spsh` function? It's documentation (which is causing the installation to fail since it's missing a "@end deftypefn" at the end) says it's an internal function but greping the package shows it's never being used. Should it be removed?

Also, private/internal functions should either be moved into the private directory, or renamed _foo_name_.

Carnë Draug <carandraug>
Project Member
Tue 31 Dec 2013 04:59:12 PM UTC, comment #11:

@comment 10:
No, 1.3.2 is obviously outdated & superseded, needless to try it, please test 1.3.6.

@comment 9:
- MXE still uses 4.13a and on Mageia 2 (my Linux cross-build box) texinfo is also 4.13a. So I just can't check with texinfo 5.2 ATM, sorry.
Could you try:
in Octave itself (= from the Octave prompt)? I think io should install fine then, despite the texinfo message.
If this doesn't work, and you still get get_first_help_sentence errors, I can only suspect that this script (in core Octave) simply isn't compatible yet with texinfo 5.2

- There's a texinfo error msg from test_spsh.m, will be fixed.

- The "out of bound error" you see looks like a bug in get_first_help_sentence.m (in scripts/help/). When I get time I'll try to investigate further.

Thanks for reporting.

For the rest:

- I saw other errors in <io>/private/__OCT_cc__.m. Will fix.

- JXL needs a bit of checking (Java input stream release).

I think with those fixes io-2.0.0 can be made (and released the official way this time).

Philip Nienhuis <philipnienhuis>
Project MemberIn charge of this item.
Tue 31 Dec 2013 04:00:41 AM UTC, comment #10:

Version 1.3.2 installs, version 1.3.3 does not install

Anonymous
Tue 31 Dec 2013 03:48:05 AM UTC, comment #9:

I have run into an issue trying to build io 1.3.6 (and 1.3.5) with Octave 3.8.0, I am not sure if it is relevant, but texinfo is version 5.2 .

'octave -f --eval "pkg build -verbose -nodeps builddir ../io-1.3.6.tar.gz"'

mkdir (/tmp/oct-uCjhna)
untar (../io-1.3.6.tar.gz, /tmp/oct-uCjhna)
make: Entering directory '/tmp/oct-uCjhna/io/src'
mkoctfile csvexplode.cc
mkoctfile csv2cell.cc
mkoctfile csvconcat.cc
mkoctfile cell2csv.cc
mkoctfile -c xmlread.cc
mkoctfile -c xmltree_read.c
mkoctfile -c xmltree.c
mkoctfile xmlread.o xmltree_read.o xmltree.o
make: Leaving directory '/tmp/oct-uCjhna/io/src'
copyfile /tmp/oct-uCjhna/io/src/cell2csv.oct /tmp/oct-uCjhna/io/src/csv2cell.oct /tmp/oct-uCjhna/io/src/csvconcat.oct /tmp/oct-uCjhna/io/src/csvexplode.oct /tmp/oct-uCjhna/io/src/xmlread.oct /tmp/oct-uCjhna/io/inst/x86_64-unknown-linux-gnu-api-v49+
/tmp/octave-help-qCeaRg:97: @bye seen before @end deftypefn
A(I): index out of bounds; value 1 out of bound 0
error: called from 'get_first_help_sentence>first_sentence_texinfo' in file /usr/share/octave/3.8.0/m/help/get_first_help_sentence.m near line 127, column 13
error: called from:
error: /usr/share/octave/3.8.0/m/pkg/private/install.m at line 241, column 5
error: /usr/share/octave/3.8.0/m/pkg/private/build.m at line 50, column 3
error: /usr/share/octave/3.8.0/m/pkg/pkg.m at line 516, column 7

Anonymous
Mon 30 Dec 2013 10:42:35 PM UTC, comment #8:

And here's io-1.3.6

- OCT interface further improved

- OpenXLS write support (OK for .xls/BIFF8, still a bit wonky for .xlsx/OOXML but that's an upstream issue)

- Documentation updated (still only html :-( )

- More extensive test scripts

This version is probably very close to the io-2.0.0 version. Please test.

(title adapted to new version; Markus (xlsxread dev) added to cc)

(file #30137)

Philip Nienhuis <philipnienhuis>
Project MemberIn charge of this item.
Fri 20 Dec 2013 10:30:38 PM UTC, comment #7:

Here is io-1.3.5 (unstable), meant for Octave >= 3.7.2

Included are OCT interface (read support for .xlsx (OOXML), gnumeric, and ODS, all w/o any support software like Java or ActiveX/Excel.

(title adapted to new version)

(file #30053)

Philip Nienhuis <philipnienhuis>
Project MemberIn charge of this item.
Thu 15 Aug 2013 08:27:36 PM UTC, comment #6:

Here's io-1.3.3
This is only meant for dev version > 3.7.2.
Apart from deeply nested Java calls different from those in io-1.2.3 it is functionally equivalent to io-1.2.3 uploaded to the package release tracker today.

Title adapted.

(file #28857)

Philip Nienhuis <philipnienhuis>
Project MemberIn charge of this item.
Sun 30 Jun 2013 05:58:41 PM UTC, comment #5:

Jordi, after re-reading your comment #4 I think you missed the fine details.

It's not stable core Octave that could/might be fixed, but the OF Java package - however, that has been absorbed in development core Octave, and its sources have already disappeared from Sourceforge.
The latter action (not by me) may have been a bit too hastily; there are a few other patches/requests for the Java package lying around (see bug #39065 & bug #39063) that would have been useful in a new Java package release. Well, too bad.

But backporting from core Octave to the (halfway deprecated) OF Java package those API changes required for io-1.3.2 to work with stable, is indeed quite a lot of work and -with a new stable Octave close by- actually ridiculous.
Moreover that wouldn't add much as the functionality of io-1.2.2 and io-1.3.2 is equivalent & they contain the same bug fixes. The main differences comprise specific Java calls - some deep in nested loops so if/else on Octave version wouldn't help performance.

All in all this is a bit of a special situation.

Philip Nienhuis <philipnienhuis>
Project MemberIn charge of this item.
Fri 28 Jun 2013 07:03:25 PM UTC, comment #4:

Yeah, maintaining stable releases is a chore, and I was expecting you to think that doing so was too complicated or too much work. As you wish; I don't find patching the Octave stable branch to be too difficult, but take your pick.

Jordi Gutiérrez Hermoso <jordigh>
Project Administrator
Fri 28 Jun 2013 06:52:20 PM UTC, comment #3:

That did cross my mind, already 6 months or more ago.

Yet I have no plans, and I see no need, to update io for the 3.6.x branch. In addition the Java package (an io dependency) won't be updated anymore either. Lastly it would be a bit strange to make a new io release that doesn't work with current stable 3.6.4.

All in all I don't see any pressing need for seperate io branches.

But generally, if a change in Octave's API affects an OF package (for io the Java stuff) you'd be right.

Philip Nienhuis <philipnienhuis>
Project MemberIn charge of this item.
Fri 28 Jun 2013 05:52:00 PM UTC, comment #2:

It seems to me that it makes sense to have two separate branches for the io package, one for Octave stable and one for Octave development.

Perhaps this could be done for any OF package as needed.

Jordi Gutiérrez Hermoso <jordigh>
Project Administrator
Fri 28 Jun 2013 05:27:25 PM UTC, comment #1:

And here's the patch to include io-1.3.2.tar.gz in mxe-octave

(file #28443)

Philip Nienhuis <philipnienhuis>
Project MemberIn charge of this item.
Fri 28 Jun 2013 02:24:51 PM UTC, original submission:

Attached is (experimental) io-1.3.2.tar.gz, which has been fixed to work with Octave 3.7.2+ ONLY.
IT WILL NOT RUN WITH Octave 3.6.x and before (sorry for shouting)
I haven't put it up on SF as this version is just a temporary development version.

Later today I'll add a changeset to include it in mxe-octave (rather than the io-1.2.0 version for which the spreadsheet I/O only works with the windows package)

Philip Nienhuis <philipnienhuis>
Project MemberIn charge of this item.

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #30137:  io-1.3.6.tar.gz added by philipnienhuis (209kB - application/x-gzip)
file #30053:  io-1.3.5.tar.gz added by philipnienhuis (206kB - application/x-gzip)
file #28857:  io-1.3.3.tar.gz added by philipnienhuis (175kB - application/x-gzip)
file #28443:  io132.cs added by philipnienhuis (1kB - text/x-csharp)
file #28441:  io-1.3.2.tar.gz added by philipnienhuis (175kB - application/x-gzip)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by philipnienhuis
  • -unavailable- added by jordigh (Posted a comment)
  • -unavailable- added by philipnienhuis (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 13 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Wed 01 Jan 2014 11:07:04 PM UTCphilipnienhuisStatusReady For Test=>Done
      Open/ClosedOpen=>Closed
    Mon 30 Dec 2013 10:42:35 PM UTCphilipnienhuisAttached File-=>Added io-1.3.6.tar.gz, #30137
      Summaryio-1.3.5 (for Octave development version 3.7.2+ ONLY)=>io-1.3.6 (for Octave development version 3.7.2+ ONLY)
      Carbon-Copy-=>Added -unavailable-
    Fri 20 Dec 2013 10:30:38 PM UTCphilipnienhuisAttached File-=>Added io-1.3.5.tar.gz, #30053
      Assigned toNone=>philipnienhuis
      Summaryio-1.3.3 (for development version ONLY)=>io-1.3.5 (for Octave development version 3.7.2+ ONLY)
    Thu 15 Aug 2013 08:27:36 PM UTCphilipnienhuisAttached File-=>Added io-1.3.3.tar.gz, #28857
      Summaryio-1.3.2 (for development version ONLY)=>io-1.3.3 (for development version ONLY)
    Fri 28 Jun 2013 05:27:47 PM UTCphilipnienhuisAssigned tophilipnienhuis=>None
    Fri 28 Jun 2013 05:27:25 PM UTCphilipnienhuisAttached File-=>Added io132.cs, #28443
    Fri 28 Jun 2013 02:24:51 PM UTCphilipnienhuisAttached File-=>Added io-1.3.2.tar.gz, #28441

    Back to the top


    Powered by Savane 3.1-cleanup