patchThe GNU Bourne-Again SHell - Patches: patch #7586, Allow chaining of !! history...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

patch #7586: Allow chaining of !! history expansion

Submitted by:  Christy O'Reilly <christyor73>
Submitted on:  Wed 27 Jul 2011 09:36:09 PM UTC  
 
Category: NonePriority: 5 - Normal
Status: NonePrivacy: Public
Assigned to: NoneOpen/Closed: Open

Wed 27 Jul 2011 09:36:09 PM UTC, original submission:

A patch to allow chaining of !! style history expansion, i.e.

!! == !-1
!!! == !-2
!!!! == !-3

Implemented as a quick alternative to reaching to opposite sides of the keyboard to type !-<low_number>

Tests and documentation have also been updated.

Git patch attached.

Cheers,

Christy

Christy O'Reilly <christyor73>

 

Attached Files

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by christyor73 (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follows 1 latest change.

    Date Changed By Updated Field Previous Value => Replaced By
    Wed 27 Jul 2011 09:36:09 PM UTCchristyor73Attached File-=>Added chained_double_bang_history_expansion.patch, #23705

    Back to the top


    Powered by Savane 3.1-cleanup