patchGNU TeXmacs - Patches: patch #6079, Mathematica plugin doesn't work...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

patch #6079: Mathematica plugin doesn't work under Mathematica 6.0

Submitted by:  Ilmari Vacklin <wolverian>
Submitted on:  Sat 07 Jul 2007 05:56:56 PM UTC  
 
Category: PluginsAction: Update
Privacy: PublicAssigned to: Andrey Grozin <grozin>
Open/Closed: ClosedRelease: 
Fixed Release: Stable: 

(Jump to the original submission Jump to the original submission)

Tue 04 Mar 2014 10:06:32 PM UTC, comment #9:

Yes, the current patch can be considered as being applied.
( I keep the idea of an item on the wishlist for the improvement of the Mathematica plugin ).

Bertrand Bratschi <bbr>
Tue 04 Mar 2014 08:03:02 AM UTC, comment #8:

Thanks for your quick answer, Bertrand. More specifically, should I consider the current patch as being applied? If there are still bugs or ideas for improvement, then it might be better to open an item on the buglist or on the wishlist.

Joris van der Hoeven <vdhoeven>
Project Administrator
Mon 03 Mar 2014 10:46:15 PM UTC, comment #7:

Dear Joris,

Of course that is an old patch, and some progress have been done in the meantime, for example ( thanks to Miguel and Philippe) i have now a plugin which works very well under Mathematica vs 6 to 9 on my mac (OS 10.6).
However it is very hard to install properly such a plugin on mac OS 10.7. ( problems of compilation : http://lists.gnu.org/archive/html/texmacs-dev/2013-08/msg00015.html ) . That is without considering all the other OS...Therefore yes, something could still be done :)

Bertrand Bratschi <bbr>
Mon 03 Mar 2014 09:26:54 PM UTC, comment #6:

Bertrand / Andrey: should something still be done by me,
or has this patch been taken care of in the meantime,
so that I can close it?

Joris van der Hoeven <vdhoeven>
Project Administrator
Sat 28 Feb 2009 09:41:09 PM UTC, comment #5:

Je crois avoir trouvé la réponse à ma question.
Il ne s'agit vraissemblablement pas d'un problème du plugin mais du fait que le mathlink.h standard ne fonctionne que pour ppc-processeur ( 32 ou 64 bits ) et non pour mac intel.

Code mathlink.h (near line 80) :
# if _ppc || __ppc_ || ppc
# define PPC_DARWIN_MATHLINK 1
# elif _ppc64 || __ppc64_ || ppc64
# define PPC64_DARWIN_MATHLINK 1
# else not yet implemented

Je viens d'ecrire à -unavailable- pour demander si il existe une version de MathLink pour mac intel.

Bertrand Bratschi <bbr>
Wed 25 Feb 2009 10:16:17 PM UTC, comment #4:

I 'm desperately trying to run a Mathematica session ( Mathematica v5 or v6 for mac ) on texmacs (1.0.7 ) using a macintosh ( intel OS 10.4 ).

The plugin doen't work.

I tryed to modify the tm_mathematica file for running Makefile.lazy file in the Mathematica plugin directory ( that makes compilation work ).

1) replacing inside all the "$TEXMACS_HOME_PATH" with "/usr/libexec/TeXmacs"

2) exporting MATHLINK_PATH=" /Applications/Mathematica/Mathematica\ 5\ .app/ AddOns/MathLink/DeveloperKit/Darwin/CompilerAdditions/"

As a result :

gcc -o /sw/share/TeXmacs/plugins/mathematica/bin/tm_mathematica src.lazy/tm_mathematica.c -I /Users/atiyab/Desktop/AddOns/MathLink/DeveloperKit/Darwin/CompilerAdditions/ -L /Users/atiyab/Desktop/AddOns/MathLink/DeveloperKit/Darwin/CompilerAdditions/ -lML -lm -lpthread -lrt
In file included from src.lazy/tm_mathematica.c:16:

/Users/atiyab/Desktop/AddOns/MathLink/DeveloperKit/Darwin/CompilerAdditions/mathlink.h:88: error: parse error before 'yet'

/Users/atiyab/Desktop/AddOns/MathLink/DeveloperKit/Darwin/CompilerAdditions/mathlink.h:391: error: syntax error before 'enum'

src.lazy/tm_mathematica.c: In function 'command':
src.lazy/tm_mathematica.c:147: warning: passing argument 2 of 'MLGetString' from incompatible pointer type

Tanks for any idea !!
bbr

Bertrand Bratschi <bbr>
Mon 31 Dec 2007 07:47:36 AM UTC, comment #3:

No no no!!!

I understand now. I've made some more testing and here's what i've found.

The patch to the Makefile is necessary but the part of replacing the "$TEXMACS_HOME_PATH" is just nonsense, just forget it.

Everything else is right, and it WORKS!

Cheers!

SBP <syr>
Mon 31 Dec 2007 07:34:35 AM UTC, comment #2:

I've found a solution to this problem.

I'm attaching a patch to the Makefile.lazy file in the Mathematica plugin directory that makes compilation work. The only thing it does is to change "-lML" to "-lML32i3".

Also it's necessary to issue this command:
ln -s /usr/mathematica/SystemFiles/Links/MathLink/DeveloperKit/Linux/CompilerAdditions/libML.so.3.16.32 /usr/lib/libML32i3.so
so that "tm_mathematica.bin" finds this lib at runtime.

I also replaced inside the tm_mathematica file all the "$TEXMACS_HOME_PATH" with "/usr/libexec/TeXmacs" which is the directory which suits according to my installation.

I don't know if this is necessary for it to run, but it works this way.

Hope this helps.

SBP

(file #14725)

SBP <syr>
Sat 07 Jul 2007 05:59:27 PM UTC, comment #1:

I forgot to mention that this patch doesn't actually make the plugin work for me. Compilation stills fails due to ld not finding -lML. I don't know what that issue is, but I don't think it's caused by this patch.

Ilmari Vacklin <wolverian>
Sat 07 Jul 2007 05:56:56 PM UTC, original submission:

The Mathematica plugin apparently looks for the headers and libraries in the wrong place. Attached is a patch that fixes this, but probably breaks compatibility for older Mathematica versions. I don't have those at hand, so can't test. I don't know how to test for the Mathematica version (besides looking at the path -- I guess that would work). Anyway, here's the naive patch just to make the issue known.

Ilmari Vacklin <wolverian>

 

Attached Files
file #14725:  Makefile.lazy.patch added by syr (569B - text/x-patch - patch to plugin makefile)
file #13265:  diffs added by wolverian (427B - application/octet-stream - fix tm_mathematica's paths)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by vdhoeven (Posted a comment)
  • -unavailable- added by bbr (Posted a comment)
  • -unavailable- added by syr (Updated the item)
  • -unavailable- added by wolverian (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 6 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Wed 05 Mar 2014 09:57:03 AM UTCvdhoevenOpen/ClosedOpen=>Closed
    Mon 03 Mar 2014 10:10:16 PM UTCvdhoevenAssigned tovdhoeven=>grozin
    Mon 03 Mar 2014 09:26:54 PM UTCvdhoevenActionNone=>Update
      Assigned toNone=>vdhoeven
    Mon 31 Dec 2007 07:34:35 AM UTCsyrAttached File-=>Added Makefile.lazy.patch, #14725
    Sat 07 Jul 2007 05:56:57 PM UTCwolverianAttached File-=>Added diffs, #13265

    Back to the top


    Powered by Savane 3.1-cleanup