patchGNU TeXmacs - Patches: patch #10436, initial support for Qt6

 
 

You are not allowed to post comments on this tracker with your current authentication level.

patch #10436: initial support for Qt6

Submitter:  PikachuHy <pikachuhy>
Submitted:  Tue 05 Mar 2024 05:06:15 PM UTC
   
 
Category:  None Action:  None
Privacy:  Public Assigned to:  None
Open/Closed:  Open Release: 
Fixed Release:  Stable: 

Tue 05 Mar 2024 05:06:15 PM UTC, original submission:  

This is the first patch of Qt6 support in TeXmacs. I've validated on it using Qt5 and Qt6 on a MacOS. I'm not that great with makefiles, so as things stand, it's set up for CMake and Qt6 building. I've tried to point out all the spots where Qt5 and Qt6 don't see eye to eye and linked back to the Qt docs for clarity. Ran into a little hiccup because Qt6 demands C++17 or newer, which means std::binary_function is out of the picture. I've dealt with that by slapping #if #endif around the code that's affected, although it's a tad bulky.

PikachuHy <pikachuhy>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attached Files
file #55786:  initial-support-for-Qt6.diff added by pikachuhy (34KiB - application/octet-stream - hi vdhoeven. I'm new to using svn and savannah, so if I've goofed up at any point, I'm really sorry about that. Looking forward to your comments. from pikachuhy )

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by pikachuhy (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

     

    Follows 1 latest change.

    Date Changed by Updated Field Previous Value => Replaced by
    2024-03-05 pikachuhy Attached File- Added initial-support-for-Qt6.diff, #55786

    Back to the top

    Powered by Savane 3.13-a854.
    Corresponding source code