bugGNU Octave - Bugs: bug #38540, generate_html package:...

 
 

bug #38540: generate_html package: html_help_text fails with embedded TeX under Octave 3.7

Submitted by:  Mike Miller <mtmiller>
Submitted on:  Mon 18 Mar 2013 02:14:25 PM UTC  
 
Category: Octave Forge PackageSeverity: 3 - Normal
Priority: 5 - NormalItem Group: Incorrect Result
Status: Wont FixAssigned to: Mike Miller <mtmiller>
Originator Name: Open/Closed: Closed
Release: devOperating System: Any

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Fri 14 Feb 2014 02:08:33 AM UTC, comment #3:

This bug does not affect me anymore. I think because I removed @iftex and @end iftex around @tex blocks in accordance with the docstring tips here:

https://www.gnu.org/software/octave/doc/interpreter/Documentation-Tips.html

I have been able to use generate_package_html in Octave 3.8.0 without this error. I'm going to close this as not a problem, but feel free to reopen if this still affects anyone else.

Mike Miller <mtmiller>
Project MemberIn charge of this item.
Fri 22 Mar 2013 11:58:04 AM UTC, comment #2:

Thanks Carlo, I see what you're saying about those markers being used to search for particular points in the makeinfo output.

I've got a potential fix now that I see what's going on, I just want to do some more testing to make sure the results look the same as before with Octave 3.6.

Mike Miller <mtmiller>
Project MemberIn charge of this item.
Mon 18 Mar 2013 06:16:32 PM UTC, comment #1:

try the following:

you will see that _makeinfo_ automatically adds its default header and footer to the docstring.
The "start" and "stop" strings are sort of bookmarks added so that the default header and footer can be replaced by those chosen in the the package options

http://sourceforge.net/p/octave/code/11750/tree/trunk/octave-forge/extra/generate_html/inst/html_help_text.m#l97

c.

Carlo de Falco <cdf>
Project Member
Mon 18 Mar 2013 02:14:25 PM UTC, original submission:

The html_help_text function used for building Octave Forge packages fails under Octave 3.7 on any functions with embedded @tex with errors like the following:

/tmp/octave-help-uMx4YA:176: Expected `
@end iftex'.
/tmp/octave-help-uMx4YA:73: No matching `@end deftypefn'.
error: html_help_text: couln't parse file 'xcorr'
error: called from:
error: /home/mike/octave/generate_html-0.1.5/html_help_text.m at line 77, column 9

The reason is because html_help_text inserts a header and footer on the function help text before passing it in to _makeinfo_:

https://sourceforge.net/p/octave/code/11750/tree/trunk/octave-forge/extra/generate_html/inst/html_help_text.m#l61

This makes the help text formatting inconsistent and breaks with the new _makeinfo_ function.

Is there any use for this header and footer addition to the help text? If no one sees any purpose for it it should be deleted since it causes problems going forward.

Mike Miller <mtmiller>
Project MemberIn charge of this item.

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by cdf (Posted a comment)
  • -unavailable- added by mtmiller (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 4 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Fri 14 Feb 2014 02:08:33 AM UTCmtmillerStatusIn Progress=>Wont Fix
      Open/ClosedOpen=>Closed
    Fri 22 Mar 2013 12:01:15 PM UTCmtmillerStatusNone=>In Progress
      Assigned toNone=>mtmiller

    Back to the top


    Powered by Savane 3.1-cleanup