bugGNU Octave - Bugs: bug #38226, "Bad image" in tsa-4.2.4...

 
 

bug #38226: "Bad image" in tsa-4.2.4 Mex files, MinGW+WindowsXP

Submitted by:  Andreas Weber <andy1978>
Submitted on:  Fri 01 Feb 2013 03:44:41 PM UTC  
 
Category: Octave Forge PackageSeverity: 3 - Normal
Priority: 5 - NormalItem Group: None
Status: NoneAssigned to: None
Originator Name: Andreas WeberOpen/Closed: Open
Release: 3.6.2Operating System: Microsoft Windows

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 02 Feb 2013 05:49:59 PM UTC, comment #3:

It's ok. We need to move the bug reports from that tracker to here but there's little free time.

Could you please give a try to the tsa and nan packages mentioned on the package release tracker https://sourceforge.net/p/octave/package-releases/1 and see if that fixes your issue?

And yes, you shouldn't try to get the help text of covm_mex. Not because that mex files don't have help text but because this function is meant to be private and only used by covm().

Carnë Draug <carandraug>
Project Member
Sat 02 Feb 2013 09:07:10 AM UTC, comment #2:

I have to insist that I've only searched for this bug on savannah, not sf. Now I've found your comment
<<Oh, had never before had to use mex files so had to do some googling. I assumed they were just like oct, no idea they couldn't have help text.>>

So my "help covm_mex" doesn't make sense at all?
Regards, Andy

Andreas Weber <andy1978>
Project Member
Fri 01 Feb 2013 10:17:35 PM UTC, comment #1:

I think the problem are some files on the package that are there because of matlab users. This is the same as the bug reported at https://sourceforge.net/p/octave/bugs/141/ where the other problematic files are also listed.

Also, the comment https://sourceforge.net/p/octave/package-releases/1/#f852 on the new version package release.

Carnë Draug <carandraug>
Project Member
Fri 01 Feb 2013 03:44:41 PM UTC, original submission:

I've installed Octave-3.6.2-mingw + octaveforge pkgs
from http://sourceforge.net/projects/octave/files/Octave%20Windows%20binaries/Octave%203.6.2%20for%20Windows%20MinGW%20installer/.

When I run "lookfor xyz" (any search term will work) I get a Windows Message box popped up with
Title: octave.exe - Bad Image
MsgText: The application or DLL f:\octave\octave3.6.2_gcc4.6.2\lib\octave\packages\tsa-4.2.4\i686-pc-mingw32-api-v48+\covm_mex.mex is not a valid Windows image. Please check this against your installation diskette."

After clicking OK, the same message for sumskipnan_mex.mex

This can also be triggered with "help covm_mex" in the tsa folder

So I guess there went something wrong when building tsa on MinGW?

Regards, Andy

Andreas Weber <andy1978>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by carandraug (tsa and nan packages author and maintainer)
  • -unavailable- added by andy1978 (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follows 1 latest change.

    Date Changed By Updated Field Previous Value => Replaced By
    Sat 02 Feb 2013 05:49:59 PM UTCcarandraugCarbon-Copy-=>Added -unavailable-

    Back to the top


    Powered by Savane 3.1-cleanup