bugGNU Octave - Bugs: bug #38085, image package: fails to build with...

 
 

bug #38085: image package: fails to build with --enable-64

Submitted by:  Carnë Draug <carandraug>
Submitted on:  Mon 14 Jan 2013 06:31:05 PM UTC  
 
Category: Octave Forge PackageSeverity: 3 - Normal
Priority: 5 - NormalItem Group: Build Failure
Status: ConfirmedAssigned to: None
Originator Name: Open/Closed: Open
Release: devOperating System: Any

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Mon 16 Mar 2015 03:41:36 PM UTC, comment #7:

The line numbers don't seem to match what I see in _spatial_.cc at revision faa0a913015f. Regardless, the problem seems to be with the following function:

A first weirdness is that it's templating the return value ET_OUT, yet it's always returning a double. I think the template argument ET_OUT is probably unnecessary, or else entropy should be changed to type ET_OUT so that it can use both float and double types.

As to the actual bug, I assume the problem is that `vals (i) + add` is returning octave_int8 values, but those can't be used for indexing. I don't even know why this used to work. I can't see what conversion path was used when octave_idx_type was int.

I think a simple fix might be to change those lines to

Jordi Gutiérrez Hermoso <jordigh>
Project Administrator
Sun 15 Mar 2015 04:15:51 AM UTC, comment #6:

Mike: That is what I thought. Just checking for the record.

Michael Godfrey <godfrey>
Sun 15 Mar 2015 03:10:44 AM UTC, comment #5:

Packages can be built and installed for both, but no a package built for 32-bit-indexed Octave won't work with 64-bit-indexed Octave, and vice versa.

Mike Miller <mtmiller>
Project Member
Sun 15 Mar 2015 02:36:30 AM UTC, comment #4:

Right, but can a package built with 64-bit indexing run
with 32-bit indexing Octave in any case?

Michael Godfrey <godfrey>
Sun 15 Mar 2015 02:28:31 AM UTC, comment #3:

No, this is not a release blocker. This relates to the image package anyway, not to any failure within Octave.

Mike Miller <mtmiller>
Project Member
Sun 15 Mar 2015 02:20:06 AM UTC, comment #2:

Mike: Just a clarification: is 64-bit integer build
supported for the 4.0 release? I thought that it is
not.

So if 64-bit is not not supported, this needs fixing,
but not before 4.0 release.

Michael Godfrey <godfrey>
Sun 15 Mar 2015 02:00:44 AM UTC, comment #1:

Confirmed, still fails to install using the current development branches of Octave (built with 64-bit index type) and the image package. At a glance the error messages look the same.

Mike Miller <mtmiller>
Project Member
Mon 14 Jan 2013 06:31:05 PM UTC, original submission:

The following bug was reported on the mailing list by Fredrik Lingvall <fredrik.lingvall@gmail.com>. Original can be seen on nabble.


I have Octave configured with --enable-64 and I can't get the image package to build with this setup:

Carnë Draug <carandraug>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Digest:
   bug dependencies.

 

Carbon-Copy List
  • -unavailable- added by jordigh (Posted a comment)
  • -unavailable- added by godfrey (Posted a comment)
  • -unavailable- added by mtmiller (Posted a comment)
  • -unavailable- added by carandraug (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 2 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sun 15 Mar 2015 02:16:42 AM UTCmtmillerDependencies-=>bugs #43908 is dependent
    Sun 15 Mar 2015 02:00:44 AM UTCmtmillerStatusNone=>Confirmed

    Back to the top


    Powered by Savane 3.1-cleanup