bugGNU GRUB - Bugs: bug #37938, GRUB-2.00 -Werror was extended to...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #37938: GRUB-2.00 -Werror was extended to HOST_CFLAGS but not -Wno-trampolines

Submitted by:  Kai Pöritz <latenite>
Submitted on:  Sun 16 Dec 2012 08:02:43 PM UTC  
 
Category: CompilationSeverity: Major
Priority: 5 - NormalItem Group: Software Error
Status: FixedPrivacy: Public
Assigned to: NoneOriginator Name: Kai Poeritz
Open/Closed: ClosedRelease: 
Release: otherReproducibility: Every Time
Planned Release: None

Sun 16 Dec 2012 08:02:43 PM UTC, original submission:

I did build ftp://ftp.gnu.org/gnu/grub/grub-2.00.tar.gz on Gentoo with:

173 grub-2.00 # gcc -v
Using built-in specs.
COLLECT_GCC=/usr/x86_64-pc-linux-gnu/gcc-bin/4.5.4/gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-pc-linux-gnu/4.5.4/lto-wrapper
Target: x86_64-pc-linux-gnu
Configured with: /var/tmp/portage/sys-devel/gcc-4.5.4/work/gcc-4.5.4/configure --prefix=/usr --bindir=/usr/x86_64-pc-linux-gnu/gcc-bin/4.5.4 --includedir=/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.4/include --datadir=/usr/share/gcc-data/x86_64-pc-linux-gnu/4.5.4 --mandir=/usr/share/gcc-data/x86_64-pc-linux-gnu/4.5.4/man --infodir=/usr/share/gcc-data/x86_64-pc-linux-gnu/4.5.4/info --with-gxx-include-dir=/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.4/include/g++-v4 --host=x86_64-pc-linux-gnu --build=x86_64-pc-linux-gnu --disable-altivec --disable-fixed-point --without-ppl --without-cloog --disable-lto --enable-nls --without-included-gettext --with-system-zlib --enable-obsolete --disable-werror --enable-secureplt --enable-multilib --enable-libmudflap --disable-libssp --enable-libgomp --with-python-dir=/share/gcc-data/x86_64-pc-linux-gnu/4.5.4/python --enable-checking=release --disable-libgcj --enable-languages=c,c++,fortran --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu --enable-targets=all --with-bugurl=http://bugs.gentoo.org/ --with-pkgversion='Gentoo 4.5.4 p1.0, pie-0.4.7'
Thread model: posix
gcc version 4.5.4 (Gentoo 4.5.4 p1.0, pie-0.4.7)

And ran into this error. See attached error.log.

Kai Pöritz <latenite>

 

Attached Files
file #27108:  error.log added by latenite (34kB - text/plain - Thanks to phcoder in #grub in irc.freenode)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by phcoder (Updated the item)
  • -unavailable- added by latenite (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Thu 03 Jan 2013 09:56:17 PM UTCphcoderStatusNone=>Fixed
      Open/ClosedOpen=>Closed
    Sun 16 Dec 2012 08:02:43 PM UTClateniteAttached File-=>Added error.log, #27108

    Back to the top


    Powered by Savane 3.1-cleanup